<!DOCTYPE html>
<!--[if IE 8 ]><html class="ie8" lang="en"><![endif]-->
<!--[if (gte IE 9)|!(IE)]><!--><html lang="en"><!--<![endif]-->
<head>
	<title>Meek Mill released from prison, looks forward to resuming music career | The Chicago Defender</title>
	<meta name="viewport" content="width=device-width, height=device-height, initial-scale=1">
	<meta http-equiv="X-UA-Compatible" content="IE=Edge">
	<meta charset="utf-8" />
	<script>
		var ione_tag_manager = {"ga":{"title":"Meek Mill released from prison, looks forward to resuming music career","id":"UA-2579388-4","author":"redward298","post_type":"post","site_type":"studio","dimensions":{"dimension2":"redward298","dimension3":"203348","dimension4":"04-24-2018","dimension5":"Tue","dimension6":"21:02:40","dimension7":"Post","dimension8":"https:\/\/chicagodefender.com\/2018\/04\/24\/meek-mill-released-from-prison-looks-forward-to-resuming-music-career\/","dimension9":"Real Times Media","dimension10":"Post"}},"sonobi_lib":null,"indexexchange_lib":"\/\/js-sec.indexww.com\/ht\/p\/186774-126868215167592.js","lazyload_enable":false,"gumgum":"c27d34c4"};
		var ione_mezzobit    = ione_tag_manager; // Support legacy tags using 'ione_mezzobit'.
	</script>
		<script>
		var stylesheet_directory_uri = "https:\/\/s2.wp.com\/wp-content\/themes\/vip\/ione3",
			home_url = "https:\/\/chicagodefender.com\/",
			ajax_url = "https:\/\/chicagodefender.com\/wp-admin\/admin-ajax.php",
			ad_s = 'p',
			ad_i = 203348,
			screenSizes = [1000,768,480,320],
			resizeHooks = { all: [], 320: [], 480: [], 768: [], 1000: [] };
			</script>

<meta name="description" content="Five months after his sentencing, the rapper Meek Mill is expected to be released from prison Tuesday afternoon, according to multiple reports. Mill, also known as Robert Rihmeek Williams, tweeted out a statement Tuesday afternoon: Meek Mill ✔@MeekMill I’d like to thank God, my family, and all my public advocates for their love, support and encouragement during this difficult time. While [&#8230;]" />
	<!-- Google Tag Manager -->
	<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
	new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
	j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
	'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
	})(window,document,'script','dataLayer', 'GTM-TPR8JL');</script>
	<!-- End Google Tag Manager -->
			<script src='https://r-login.wordpress.com/remote-login.php?action=js&amp;host=chicagodefender.com&amp;id=56132093&amp;t=1524640032&amp;back=https%3A%2F%2Fchicagodefender.com%2F2018%2F04%2F24%2Fmeek-mill-released-from-prison-looks-forward-to-resuming-music-career%2F' type="text/javascript"></script>
		<script type="text/javascript">
		/* <![CDATA[ */
			if ( 'function' === typeof WPRemoteLogin ) {
				document.cookie = "wordpress_test_cookie=test; path=/";
				if ( document.cookie.match( /(;|^)\s*wordpress_test_cookie\=/ ) ) {
					WPRemoteLogin();
				}
			}
		/* ]]> */
		</script>
		<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//pdk.theplatform.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//ionechicagodefender.wordpress.com' />
<link rel="alternate" type="application/rss+xml" title="The Chicago Defender &raquo; Meek Mill released from prison, looks forward to resuming music career Comments Feed" href="https://chicagodefender.com/2018/04/24/meek-mill-released-from-prison-looks-forward-to-resuming-music-career/feed/" />
	<script type="text/javascript">
		/* <![CDATA[ */
		function addLoadEvent(func) {
			var oldonload = window.onload;
			if (typeof window.onload != 'function') {
				window.onload = func;
			} else {
				window.onload = function () {
					oldonload();
					func();
				}
			}
		}
		/* ]]> */
	</script>
			<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/s1.wp.com\/wp-includes\/js\/wp-emoji-release.min.js?m=1516999477h&ver=4.9.5"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='all-css-0-1' href='https://s0.wp.com/_static/??-eJylUNEOwiAM/CERp26JD8ZPMYzVrdsKhDKnfy+E7EXNEuNLcz1616NydkJbE8AESZNw49SiYTk7bUkw4QjPt26rmTfyu0xbD5Enp0KaIGhQwQgUx9ZkMzYthCjnBYsAj1UJuWpZlGCn9LCaLH+hrp0HZhEr4UQidDHbpy7T8o5OojVwkIo55esjB6axXvKIesh1S2j+c8gxfvJJl8pv1wR1h1q1toFbNAefbC50Lsr9sdoVZXHqX7E7thg=?cssminify=yes' type='text/css' media='all' />
<!--[if lte IE 8]>
<link rel='stylesheet' id='ione3-oldie-css'  href='https://s2.wp.com/wp-content/themes/vip/ione3/assets/css/themes_css/chicagodefender_oldie.css?ver=0.2.5' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='all-css-2-1' href='https://s0.wp.com/_static/??-eJx9j+EOgjAMhF/I0UxJ1B/GZ9nmGJWyknWIvr2oEEOM/LsvubteYeiU45h9zND2qqM+YBQY8BJ8FqiM85a5UYTNKO4g+UG+cCIbWE8KOzSkcLQs4Seca996gRt2MJeIQcp16mH0To2F9FZcQjtdR4icP+2zWJsVPCtiZzJyXICqyGBaiyZvicMow3vOF/99UpcQiK2hl+HcnnR53G8PWu/09Ql8pYln?cssminify=yes' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var ionegpt = {"tags":[],"attrs":{"pg":"meek-mill-released-from-prison-looks-forward-to-resuming-music-career","content":["post"],"author":"redward298","postname":"meek-mill-released-from-prison-looks-forward-to-resuming-music-career","slot":"meek-mill-released-from-prison-looks-forward-to-resuming-music-career","ar":"id:203348","postID":"203348"},"gptSlots":[],"debug":"","utils":{"is_home":false,"home_url":"https:\/\/chicagodefender.com"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://s2.wp.com/_static/??-eJyNj/1KxDAQxF/INFjvxH/ER5E0GXNb82V2c+V8etP6AUI5hUDI5jezM3opipINzYH13M9bQ718XcPMN/oaoCL5agRDpPQN25wESVY25okCVGNU4/usG73kHa5klgjmDu38/o5E6UxY/sRmSDH2VVUwvWOvSEsOlW2uu+nlhJ5In6loygl32jBDNuH2fraVhKwJ/xL/7I3ZtYBPD2Xc5ueLjFccSmieEms2FORU2ypZyHnIwG3inmNa+z3Fx9vjeBiPh/H+Yf4A0EWvsg=='></script>
<link rel='stylesheet' id='all-css-0-2' href='https://s1.wp.com/wp-content/mu-plugins/highlander-comments/style.css?m=1522184747h&cssminify=yes' type='text/css' media='all' />
<!--[if lt IE 8]>
<link rel='stylesheet' id='highlander-comments-ie7-css'  href='https://s2.wp.com/wp-content/mu-plugins/highlander-comments/style-ie7.css?m=1351637563h&#038;ver=20110606' type='text/css' media='all' />
<![endif]-->
<link rel="canonical" href="https://atlantadailyworld.com/2018/04/24/meek-mill-released-from-prison-looks-forward-to-resuming-music-career/" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://ionechicagodefender.wordpress.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://s1.wp.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress.com" />
<link rel='shortlink' href='https://wp.me/p3Nwwl-QTO' />
<link rel="alternate" type="application/json+oembed" href="https://public-api.wordpress.com/oembed/?format=json&amp;url=https%3A%2F%2Fchicagodefender.com%2F2018%2F04%2F24%2Fmeek-mill-released-from-prison-looks-forward-to-resuming-music-career%2F&amp;for=wpcom-auto-discovery" /><link rel="alternate" type="application/xml+oembed" href="https://public-api.wordpress.com/oembed/?format=xml&amp;url=https%3A%2F%2Fchicagodefender.com%2F2018%2F04%2F24%2Fmeek-mill-released-from-prison-looks-forward-to-resuming-music-career%2F&amp;for=wpcom-auto-discovery" />
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Meek Mill released from prison, looks forward to resuming music career" />
<meta property="og:url" content="https://chicagodefender.com/2018/04/24/meek-mill-released-from-prison-looks-forward-to-resuming-music-career/" />
<meta property="og:description" content="Five months after his sentencing, the rapper Meek Mill is expected to be released from prison Tuesday afternoon, according to multiple reports. Mill, also known as Robert Rihmeek Williams, tweeted …" />
<meta property="article:published_time" content="2018-04-25T02:02:40+00:00" />
<meta property="article:modified_time" content="2018-04-25T02:02:40+00:00" />
<meta property="og:site_name" content="The Chicago Defender" />
<meta property="og:image" content="https://abs.twimg.com/emoji/v2/72x72/1f5e3.png" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:site" content="@ChiDefender" />
<meta name="twitter:text:title" content="Meek Mill released from prison, looks forward to resuming music career" />
<meta name="twitter:image" content="https://s.yimg.com/ny/api/res/1.2/wXRLu2nTT8wNq2OYD9qtiQ--/YXBwaWQ9aGlnaGxhbmRlcjtzbT0xO3c9ODAw/http://media.zenfs.com/en-US/homerun/the_huffington_post_584/9408b97f2dc9471eba91cf9fcbe654b9?w=240" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:creator" content="@ChiDefender" />
<meta property="article:publisher" content="https://www.facebook.com/WordPresscom" />
<meta name="twitter:title" content="Meek Mill released from prison, looks forward to resuming music career" />
<meta name="twitter:description" content="Five months after his sentencing, the rapper Meek Mill is expected to be released from prison Tuesday afternoon, according to multiple reports. Mill, also known as Robert Rihmeek Williams, tweet" />
<meta property="pubexchange:headline" content="Meek Mill released from prison, looks forward to resuming music career" />
<meta property="pubexchange:description" content="Five months after his sentencing, the rapper Meek Mill is expected to be released from prison Tuesday afternoon, according to multiple reports. Mill, also known as Robert Rihmeek Williams, tweeted out a statement Tuesday afternoon: Meek Mill @MeekMi" />
<link rel="shortcut icon" type="image/x-icon" href="https://secure.gravatar.com/blavatar/b673e519ae8c96750f5225af010e4e60?s=32" sizes="16x16" />
<link rel="icon" type="image/x-icon" href="https://secure.gravatar.com/blavatar/b673e519ae8c96750f5225af010e4e60?s=32" sizes="16x16" />
<link rel="apple-touch-icon-precomposed" href="https://secure.gravatar.com/blavatar/b673e519ae8c96750f5225af010e4e60?s=114" />
<link rel='openid.server' href='https://ionechicagodefender.wordpress.com/?openidserver=1' />
<link rel='openid.delegate' href='https://ionechicagodefender.wordpress.com/' />
<link rel="search" type="application/opensearchdescription+xml" href="https://chicagodefender.com/osd.xml" title="The Chicago Defender" />
<link rel="search" type="application/opensearchdescription+xml" href="https://s1.wp.com/opensearch.xml" title="WordPress.com" />

<script type="text/javascript">var _sf_startpt=(new Date()).getTime()</script>
			<meta property="fb:pages" content="" />
			<script>var _sf_startpt=(new Date()).getTime()</script><meta name="msvalidate.01" content="30473C9E51B1FA7645F80C5736971CF1" />		<script>
					var DartOrd = Math.floor( Math.random() * 1e16 );
		</script>
		<meta name="tp:EnableExternalController" content="true" /><script type="text/javascript">var ajaxurl = "https://chicagodefender.com/wp-admin/admin-ajax.php"</script><meta name="application-name" content="The Chicago Defender" /><meta name="msapplication-window" content="width=device-width;height=device-height" /><meta name="msapplication-tooltip" content="Powered by Real Times Media" /><meta name="msapplication-task" content="name=Subscribe;action-uri=https://chicagodefender.com/feed/;icon-uri=https://secure.gravatar.com/blavatar/b673e519ae8c96750f5225af010e4e60?s=16" /><!-- iOne BEGIN Sailthru Horizon Meta Information -->

<meta name='sailthru.date' content='2018-04-24 21:02:40' />
<meta name='sailthru.title' content='Meek Mill released from prison, looks forward to resuming music career' />
<meta name='sailthru.author' content='Roz Edward' />
<meta name='sailthru.description' content='Five months after his sentencing, the rapper Meek Mill is expected to be released from prison Tuesday afternoon, according to multiple reports. Mill, also known as Robert Rihmeek Williams, tweeted out a statement Tuesday afternoon: Meek Mill ✔@MeekMill I’d like to thank God, my family, and all my public advocates for their love, support and encouragement during this difficult time. While [&#8230;]' />


<!-- iOne END Sailthru Horizon Meta Information --><link rel="amphtml" href="https://chicagodefender.com/2018/04/24/meek-mill-released-from-prison-looks-forward-to-resuming-music-career/amp/"><style type="text/css" id="syntaxhighlighteranchor"></style>
		<link rel="stylesheet" id="custom-css-css" type="text/css" href="https://s1.wp.com/?custom-css=1&#038;csblog=3Nwwl&#038;cscache=6&#038;csrev=142" />
			
		
		
					 <meta name="google-site-verification" content="xOMmFvpdY9xaFdzm33brBWFvEknjCAS3fQkeKmPe-xg" /> 			 <meta name="msvalidate.01" content="045A9DFCA943D7F788EB8555F46A71AC" /> 		 		 <style>
	.custom-header-styles {
		color:blue;
				background:url(https://ionechicagodefender.files.wordpress.com/2017/04/chicagodef-banner1.jpg?quality=100&#038;strip=all);
		}
</style>

	 <script type="text/javascript">

		 // Run through and set the timeout to refresh page if any of these are true
		 jQuery(document).ready(function ($) {
			 
			 if ($('body.home').length > 0) {
				 setTimeout(function () {
					 window.location.reload()
				 }, "300000" );
			 }
			 			 
			 if ($('body.category').length > 0) {
				 setTimeout(function () {
					 window.location.reload()
				 }, "300000" );
			 }

			 			 
			 if ($('body.single-post').length > 0) {
				 setTimeout(function () {
					 window.location.reload()
				 }, "900000" );
			 }
			 		 });
	 </script>

</head>
<!-- Add class has-gravity-ad to body if there's a gravity ad -->
<body class="post-template-default single single-post postid-203348 single-format-standard has-push-menu mp6 customizer-styles-applied no-cover-image highlander-enabled highlander-light" style="">

	<!-- Google Tag Manager (noscript) -->
	<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-TPR8JL"
	height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
	<!-- End Google Tag Manager (noscript) -->
	
<div id="global-search" class="global-search">
	<i class="icon-close global-search-close" id="global-search-close"></i>

	<!-- Search box placeholder-->
	<span class="ionesearch-box-placeholder"></span>

	<!-- Placeholder div -->
	<span id="ione-searchresults-placeholder"></span>

</div>

<!-- TEMPLATES -->
<!-- Search collection template -->
<script id="tmpl-ionesearch-collection" type="text/html">
	<div class="search-results">

		<div class="results__stories">
			<div class="search-results-title">Stories</div>
				<!-- Placeholder div -->
				<div id="ione-searchresults-stories-placeholder"></div>

		</div>
		<!-- .results__stories -->

		<div class="results__people">
			<div class="search-results-title">People</div>
				<!-- Placeholder div -->
				<div id="ione-searchresults-people-placeholder"></div>
		</div>
		<!-- .results__people -->

	</div>
	<!-- .search-results -->

	<!-- Search pagination placeholder-->
	<div id="ione-searchpagination-placeholder"></div>
</script>

<!-- Search pagination template -->
<script id="tmpl-ionesearch-pagination" type="text/html">
	<div class="search-pagination">

		<# if ( data.maxPages > 1 ) { #>
		<a
			class="search-nav-button search-previous <# if ( data.currentPage > 1 ) { #> active <# } #>"
			value="{{{ data.previousPage }}}">&larr; Previous</a>
		<div class="pagination-status">
			<span class="current-page">{{{ data.currentPage }}}</span> of <span class="max-pages">{{{ data.maxPages }}}</span>
		</div>
		<a
			class="search-nav-button search-next <# if ( data.currentPage < data.maxPages ) { #> active <# } #>"
			value="{{{ data.nextPage }}}">Next &rarr;</a>
		<# } #>

	</div>
	<!-- .search-pagination -->
</script>

<!-- Search box template -->
<script id="tmpl-ionesearch-box" type="text/html">
	<label for="global-search-field" class="search-input-header">
		<i class="icon-search"></i>
		<input type="text" placeholder="Type to search" id="global-search-field" class="global-search-field">
	</label>
	<i class="icon-close global-search-close" id="global-search-close"></i>
</script>

<!-- Search results template -->
<script id="tmpl-ionesearch-result" type="text/html">

	<div class="post has-post-thumbnail search-result {{ data.hasFocus }}">
		<a class="post-link" href="{{ data.link }}">
		<# if ( '' !== data.imageUrl ){ #>
			<img srcset="{{ data.imageUrl }} 1x, {{ data.imageRetinaUrl }} 2x" alt="{{ data.imageAlt }}">
		<# } #>
			<div class="post-meta">
				<p class="post-meta__title">{{{ data.title }}}</p>
				<p class="post-meta__lead">{{{ data.lead }}}</p>
			</div>
		</a>
	</div>

</script>

<!-- People Search results template -->
<script id="tmpl-ionesearch-result-people" type="text/html">
			<div class="post has-post-thumbnail search-result search-result--people {{ data.hasFocus }}">
				<a class="post-link" href="{{ data.link }}">
					<img alt="{{ data.imageAlt }}" src="{{ data.imageUrl }}">
					<div class="post-meta">
						<p class="post-meta__title">{{{ data.title }}}</p>
						<p class="author__position">{{ data.position }}</p>
					</div>
				</a>
			</div>
</script>
<nav class="push-menu" id="push-menu" role="navigation">
	<button id="push-menu__close" class="icon-close push-menu__close"><span class="screen-reader-text">Close menu</span></button>
	<ul id="menu-main-menu" class="push-primary-menu"><li id="menu-item-20" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-20"><a href="http://chicagodefender.com">HOME</a></li>
<li id="menu-item-15" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-15"><a href="https://chicagodefender.com/category/news/">NEWS</a>
<ul class="sub-menu">
	<li id="menu-item-65281" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-65281"><a href="https://chicagodefender.com/category/news/city/">City</a></li>
	<li id="menu-item-65282" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-65282"><a href="https://chicagodefender.com/category/news/nation/">Nation</a></li>
	<li id="menu-item-65284" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-65284"><a href="https://chicagodefender.com/category/news/c98-world/">World</a></li>
	<li id="menu-item-181278" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-181278"><a href="https://chicagodefender.com/category/c149-politics/">Politics</a></li>
	<li id="menu-item-183461" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-183461"><a href="https://chicagodefender.com/alderman-report-cards/">Alderman Report Cards</a></li>
</ul>
</li>
<li id="menu-item-86031" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-86031"><a href="https://chicagodefender.com/category/views/">VOICES</a>
<ul class="sub-menu">
	<li id="menu-item-181285" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-181285"><a href="https://chicagodefender.com/category/views/editorstake/">Editor&#8217;s Take</a></li>
	<li id="menu-item-181265" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-181265"><a href="https://chicagodefender.com/category/views/inthemix/">In the Mix</a></li>
	<li id="menu-item-181267" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-181267"><a href="https://chicagodefender.com/author/drkarenjanuary/">Dr. Karen January</a></li>
	<li id="menu-item-181281" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-181281"><a href="https://chicagodefender.com/category/views/columnists/">Featured Columnists</a></li>
</ul>
</li>
<li id="menu-item-181273" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-181273"><a href="https://chicagodefender.com/category/c99-culture/">LIFESTYLE</a>
<ul class="sub-menu">
	<li id="menu-item-181274" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-181274"><a href="https://chicagodefender.com/category/c99-culture/beauty-lifestyle/">Beauty</a></li>
	<li id="menu-item-181275" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-181275"><a href="https://chicagodefender.com/category/c99-culture/fashion-2/">Fashion</a></li>
	<li id="menu-item-181276" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-181276"><a href="https://chicagodefender.com/category/c99-culture/relationships/">Relationships</a></li>
	<li id="menu-item-65288" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-65288"><a href="https://chicagodefender.com/category/c105-health/">Health</a></li>
	<li id="menu-item-181264" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-181264"><a href="https://chicagodefender.com/category/c102-faith/">Faith</a></li>
</ul>
</li>
<li id="menu-item-182103" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-182103"><a href="https://chicagodefender.com/category/c100-entertainment/">ENTERTAINMENT</a>
<ul class="sub-menu">
	<li id="menu-item-181277" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-181277"><a href="https://chicagodefender.com/category/c100-entertainment/music-3/">Music</a></li>
	<li id="menu-item-182255" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-182255"><a href="https://chicagodefender.com/category/c100-entertainment/theatre/">Theatre</a></li>
</ul>
</li>
<li id="menu-item-65287" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-65287"><a href="https://chicagodefender.com/category/c106-business/">BUSINESS</a></li>
<li id="menu-item-86032" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-86032"><a href="https://chicagodefender.com/category/c97-sports/">SPORTS</a></li>
<li id="menu-item-181597" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-181597"><a href="https://chicagodefender.com/category/our-videos/">MEDIA</a>
<ul class="sub-menu">
	<li id="menu-item-187316" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-187316"><a href="https://chicagodefender.com/category/our-videos/">Videos</a></li>
	<li id="menu-item-187135" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-187135"><a href="https://chicagodefender.com/2017/07/09/chicago-defender-podcasts/">Podcasts</a></li>
</ul>
</li>
</ul><ul id="menu-2-footer-links" class="push-secondary-menu secondary-menu"><li id="menu-item-169905" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-169905"><a href="https://chicagodefender.com/about/">About</a></li>
<li id="menu-item-182610" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-182610"><a href="https://chicagodefender.com/dont-miss-an-issue/">Subscribe</a></li>
<li id="menu-item-169906" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-169906"><a href="https://chicagodefender.com/archives-permissions/">Archives &amp; Permissions</a></li>
<li id="menu-item-86194" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-86194"><a href="https://chicagodefender.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-86188" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-86188"><a href="http://interactiveone.com/">Interactive One Affluent</a></li>
<li id="menu-item-169907" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-169907"><a href="https://chicagodefender.com/contact-us/">Contact Us</a></li>
</ul><ul id="menu-social-media-new" class="social-menu"><li id="menu-item-155399" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-155399"><a href="https://www.facebook.com/TheChicagoDefender/"><span>Facebook</span></a></li>
<li id="menu-item-155400" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-155400"><a href="https://twitter.com/ChiDefender"><span>Twitter</span></a></li>
</ul>	<div class="push-menu__content">
		
		<p>Copyright &copy; 2018 <a href="http://interactiveone.com">Interactive One, LLC</a>.</p>
		<p>All Rights Reserved</p>
		<p>Powered by <a href="https://vip.wordpress.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=chicagodefender.com" rel="generator nofollow" class="powered-by-wpcom">WordPress.com VIP</a></p>
	</div>
</nav>
<div id="ione-container" class="push-content">
	
	<header id="header" class="main-header  has-custom-logo" role="banner">
		<div id="header-inner" class="main-header-inner">

			<div class="main-logo-wrapper ">
				<button id="menu-toggle" class="menu-toggle"><i class="icon-menu"></i></button>
				<div class="main-title ">
					<a href="https://chicagodefender.com/"><img srcset="https://ionechicagodefender.files.wordpress.com/2016/09/chicagodefender-nav-logo.png?w=211&amp;resize=9999%2C50&amp;quality=80&amp;strip=all 1x, https://ionechicagodefender.files.wordpress.com/2016/09/chicagodefender-nav-logo.png?w=211&amp;resize=9999%2C100&amp;quality=80&amp;strip=all 2x" class="navbar-logo" /></a>				</div>
			</div>

			<!-- CUSTOM MENU -->
<div class="menu-main-menu-container"><ul id="menu-main-menu-1" class="main-nav main-nav__type-standard"><li class="main-nav__item menu-item menu-item-type-custom menu-item-object-custom menu-item-home main-nav__items"><a href="http://chicagodefender.com" class="main-nav__item-link">HOME</a></li>
<li class="main-nav__item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children main-nav__items"><a href="https://chicagodefender.com/category/news/" class="main-nav__item-link">NEWS</a>
	<div class="main-nav__dropdown">
		<div class="container"><div class="post-item"><div class="post-meta__title"><a href="https://chicagodefender.com/category/news/city/" class="post-link">City</a></div></div>
<div class="post-item"><div class="post-meta__title"><a href="https://chicagodefender.com/category/news/nation/" class="post-link">Nation</a></div></div>
<div class="post-item"><div class="post-meta__title"><a href="https://chicagodefender.com/category/news/c98-world/" class="post-link">World</a></div></div>
<div class="post-item"><div class="post-meta__title"><a href="https://chicagodefender.com/category/c149-politics/" class="post-link">Politics</a></div></div>
<div class="post-item"><div class="post-meta__title"><a href="https://chicagodefender.com/alderman-report-cards/" class="post-link">Alderman Report Cards</a></div></div>

		</div>
	</div></li>
<li class="main-nav__item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children main-nav__items"><a href="https://chicagodefender.com/category/views/" class="main-nav__item-link">VOICES</a>
	<div class="main-nav__dropdown">
		<div class="container"><div class="post-item"><div class="post-meta__title"><a href="https://chicagodefender.com/category/views/editorstake/" class="post-link">Editor&#8217;s Take</a></div></div>
<div class="post-item"><div class="post-meta__title"><a href="https://chicagodefender.com/category/views/inthemix/" class="post-link">In the Mix</a></div></div>
<div class="post-item"><div class="post-meta__title"><a href="https://chicagodefender.com/author/drkarenjanuary/" class="post-link">Dr. Karen January</a></div></div>
<div class="post-item"><div class="post-meta__title"><a href="https://chicagodefender.com/category/views/columnists/" class="post-link">Featured Columnists</a></div></div>

		</div>
	</div></li>
<li class="main-nav__item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children main-nav__items"><a href="https://chicagodefender.com/category/c99-culture/" class="main-nav__item-link">LIFESTYLE</a>
	<div class="main-nav__dropdown">
		<div class="container"><div class="post-item"><div class="post-meta__title"><a href="https://chicagodefender.com/category/c99-culture/beauty-lifestyle/" class="post-link">Beauty</a></div></div>
<div class="post-item"><div class="post-meta__title"><a href="https://chicagodefender.com/category/c99-culture/fashion-2/" class="post-link">Fashion</a></div></div>
<div class="post-item"><div class="post-meta__title"><a href="https://chicagodefender.com/category/c99-culture/relationships/" class="post-link">Relationships</a></div></div>
<div class="post-item"><div class="post-meta__title"><a href="https://chicagodefender.com/category/c105-health/" class="post-link">Health</a></div></div>
<div class="post-item"><div class="post-meta__title"><a href="https://chicagodefender.com/category/c102-faith/" class="post-link">Faith</a></div></div>

		</div>
	</div></li>
<li class="main-nav__item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children main-nav__items"><a href="https://chicagodefender.com/category/c100-entertainment/" class="main-nav__item-link">ENTERTAINMENT</a>
	<div class="main-nav__dropdown">
		<div class="container"><div class="post-item"><div class="post-meta__title"><a href="https://chicagodefender.com/category/c100-entertainment/music-3/" class="post-link">Music</a></div></div>
<div class="post-item"><div class="post-meta__title"><a href="https://chicagodefender.com/category/c100-entertainment/theatre/" class="post-link">Theatre</a></div></div>

		</div>
	</div></li>
<li class="main-nav__item menu-item menu-item-type-taxonomy menu-item-object-category main-nav__items"><a href="https://chicagodefender.com/category/c106-business/" class="main-nav__item-link">BUSINESS</a></li>
<li class="main-nav__item menu-item menu-item-type-taxonomy menu-item-object-category main-nav__items"><a href="https://chicagodefender.com/category/c97-sports/" class="main-nav__item-link">SPORTS</a></li>
<li class="main-nav__item menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children main-nav__items"><a href="https://chicagodefender.com/category/our-videos/" class="main-nav__item-link">MEDIA</a>
	<div class="main-nav__dropdown">
		<div class="container"><div class="post-item"><div class="post-meta__title"><a href="https://chicagodefender.com/category/our-videos/" class="post-link">Videos</a></div></div>
<div class="post-item"><div class="post-meta__title"><a href="https://chicagodefender.com/2017/07/09/chicago-defender-podcasts/" class="post-link">Podcasts</a></div></div>

		</div>
	</div></li>
</ul></div>
			<div id="main-search" class="main-search">
								<!-- Go to www.addthis.com/dashboard to customize your tools -->
				<div class="addthis_custom_follow"></div>
				<i class="icon-search global-search-toggle" id="global-search-toggle"></i>
			</div>
		</div>
			</header>

	
<div id="infinite-scroll-container">
	<div class="wallpaper-ad" id="ione3-wallpaper"></div>
	<div class="post-super-wrapper" role="main" data-id="203348"  data-primary-cat="" data-permalink="https://chicagodefender.com/2018/04/24/meek-mill-released-from-prison-looks-forward-to-resuming-music-career/" data-title="Meek Mill released from prison, looks forward to resuming music career">

		<div class="in-content-widget-top">
					</div>

		<div class="post-wrapper">

			<div class="ad-single-top">
				<div class="ione-widget-container ione-widget-ionead">		<div id="ad-header-post" data-ad-id="header-post" class="ad">
					<div id="div-gpt-header-post" class="gpt-ad">
			<script type="text/javascript">
				window.ioneAds.defineSlot( {"name":"header-post","path":"\/4052\/thechicagodefender\/desktop","sizes":[[728,90],[970,66],[970,90],[970,250],[1000,200]],"div":"div-gpt-header-post","targets":{"pos":"top","sz":"728x90,970x66,970x90,970x250,1000x200"},"event_render":null,"event_refresh":null,"refresh_interval":null} );
			</script>
		</div>
				</div>
		</div>			</div>
			<!-- .ad-single-top -->

			
			<div class="post">

				<div class="post-meta">
										<div class="post-breadcrumbs"><a href="https://chicagodefender.com/">Home</a></div>						<h1 class="post-meta__title">Meek Mill released from prison, looks forward to resuming music career</h1>
																	<br>
					<div class="post-author simplified-article-author-block">
			<img src="https://ioneadwnews.files.wordpress.com/2014/10/roz1_final-3.jpg" alt="" class="post-author__avatar">
		<span class="post-meta-block">
		<!-- author name -->
		<span class="post-author__name"> <a href="https://chicagodefender.com/author/redward298/" class="post-link">Roz Edward</a></span><div class="post-meta__time"><p>Posted 5 hours ago</p></div>	</span>
</div>

					<div class="post-sharing">
						<span class="read-counter-container">
	<span class="read-counter">0</span>
	<span class="read-counter-label">reads</span>
</span>
<!-- Go to www.addthis.com/dashboard to customize your tools -->
<div class="addthis_responsive_sharing addthis-large-layout"></div>

			<a class="post-sharing-button-custom ione-toggle-triggerlink" data-name="ione-comments-203348" href="#"><i class="icon-comments"></i> <span>Leave a comment</span></a>
	
					</div>
				</div>
				<!-- .post-meta -->
								<div class="post-wrapper-content">

					
					<div class="post-content">

						<div id="YDC-Lead" class="YDC-Lead Px(55px) Pt(35px) Px(25px)--modalMinWidth">
<div id="YDC-Lead-Stack" class="YDC-Lead-Stack">
<div>
<div>
<div id="mrt-node-Lead-1-HeadComponentTitle">
<div id="Lead-1-HeadComponentTitle-Proxy">
<header id="Lead-1-HeadComponentTitle" class="canvas-header">
<h2 class="Lh(1.15) Fz(40px) Fz(36px)--modalMinWidth Mb(14px) Ff($ff-primary) Lts($lspacing-md) Fw($fweight) Fsm($fsmoothing) Fsmw($fsmoothing) Fsmm($fsmoothing) Wow(bw)"></h2>
</header>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="YDC-UniCol1 Ov(h) Pstart(55px) Pend(355px) Pstart(25px)--modalMinWidth Pend(315px)--modalMinWidth">
<div class="Fl(start) W(100%) Bxz(bb) Pend(40px)">
<div class="Pos(r)">
<div id="YDC-Col1-1" class="YDC-Col1-1 Bxz(bb) Maw(650px) Mstart(80px) Mstart(65px)--modalMinWidth">
<div id="YDC-Col1-1-Stack" class="YDC-Col1-1-Stack Pos(r) Mih(328px) Pb(45px)">
<div>
<div>
<div id="mrt-node-Col1-0-ContentCanvas">
<div id="Col1-0-ContentCanvas-Proxy">
<div id="Col1-0-ContentCanvas" class="content-canvas Bgc(#fff) Pos(r)">
<article>
<figure class="canvas-image Mx(a) canvas-atom Mt(0) Mt(20px)--sm Mb(24px) Mb(22px)--sm Ta(c)">
<div class="Maw(100%) D(ib)"><img class=" Maw(100%)" src="https://s0.wp.com/wp-content/themes/vip/plugins/lazy-load-0.7/images/1x1.trans.gif" data-lazy-src="https://s.yimg.com/ny/api/res/1.2/wXRLu2nTT8wNq2OYD9qtiQ--/YXBwaWQ9aGlnaGxhbmRlcjtzbT0xO3c9ODAw/http://media.zenfs.com/en-US/homerun/the_huffington_post_584/9408b97f2dc9471eba91cf9fcbe654b9"><noscript><img class=" Maw(100%)" src="https://s.yimg.com/ny/api/res/1.2/wXRLu2nTT8wNq2OYD9qtiQ--/YXBwaWQ9aGlnaGxhbmRlcjtzbT0xO3c9ODAw/http://media.zenfs.com/en-US/homerun/the_huffington_post_584/9408b97f2dc9471eba91cf9fcbe654b9" /></noscript></div>
</figure>
<div class="canvas-body Wow(bw) Cl(start) Mb(20px) Lh(30px) Fz(18px) Ff(s) C(#000) D(i)">
<p class="canvas-atom canvas-text Mb(1.0em) Mb(0)--sm Mt(0.8em)--sm" style="margin:0 0 1em;">Five months after his sentencing, the rapper <a href="https://www.huffingtonpost.com/topic/meek-mill" target="_blank" rel="nofollow noopener" target="_blank">Meek Mill</a> is expected to be released from prison Tuesday afternoon, <a href="http://www.tmz.com/2018/04/24/meek-mill-released-from-prison/" target="_blank" rel="nofollow noopener" target="_blank">according</a> to <a href="https://twitter.com/FOX29philly/status/988866702942330882" target="_blank" rel="nofollow noopener" target="_blank">multiple reports</a>.</p>
<p class="canvas-atom canvas-text Mb(1.0em) Mb(0)--sm Mt(0.8em)--sm">Mill, also known as Robert Rihmeek Williams, tweeted out a statement Tuesday afternoon:</p>
<div class="canvas-tweet canvas-atom Ov(a) W(100%)">
<div class="SandboxRoot env-bp-350">
<div id="twitter-widget-0" class="EmbeddedTweet EmbeddedTweet--edge js-clickToOpenTarget tweet-InformationCircle-widgetParent" lang="en">
<div class="EmbeddedTweet-tweet">
<blockquote class="Tweet h-entry js-tweetIdInfo subject expanded" cite="https://twitter.com/MeekMill/status/988871657111498752">
<div class="Tweet-header"><a target="_blank"><img class="Avatar Avatar--edge" src="https://s0.wp.com/wp-content/themes/vip/plugins/lazy-load-0.7/images/1x1.trans.gif" alt data-lazy-src="https://pbs.twimg.com/profile_images/646884416304713728/jrqMaIdO_normal.jpg"><noscript><img class="Avatar Avatar--edge" src="https://pbs.twimg.com/profile_images/646884416304713728/jrqMaIdO_normal.jpg" alt="" /></noscript></a></p>
<div class="TweetAuthor js-inViewportScribingTarget">
<div class="TweetAuthor-nameScreenNameContainer"><span class="TweetAuthor-decoratedName"><span class="TweetAuthor-name Identity-name customisable-highlight" title="Meek Mill">Meek Mill</span></span></p>
<div class="Icon Icon--verified " title="Verified Account" role="img"></div>
<p><span class="TweetAuthor-decoratedName"><span class="TweetAuthor-verifiedBadge"><b class="u-hiddenVisually"><img src="https://s0.wp.com/wp-content/themes/vip/plugins/lazy-load-0.7/images/1x1.trans.gif" alt="✔" class="wp-smiley" style="height:1em;max-height:1em;" data-lazy-src="https://s0.wp.com/wp-content/mu-plugins/wpcom-smileys/twemoji/2/72x72/2714.png"><noscript><img src="https://s0.wp.com/wp-content/mu-plugins/wpcom-smileys/twemoji/2/72x72/2714.png" alt="✔" class="wp-smiley" style="height:1em;max-height:1em;" /></noscript></b></span></span><span class="TweetAuthor-screenName Identity-screenName" dir="ltr" title="@MeekMill">@MeekMill</span></div>
</div>
<div class="Tweet-brand">
<div class="Icon Icon--twitter " title="View on Twitter" role="presentation"></div>
</div>
</div>
<div class="Tweet-body e-entry-content">
<div class="u-hiddenVisually js-inViewportScribingTarget"></div>
<p class="Tweet-text e-entry-title" dir="ltr" lang="en">I’d like to thank God, my family, and all my public advocates for their love, support and encouragement during this difficult time. While the past five months have been a nightmare, the prayers, visits, calls, letters and rallies have helped me stay positive.</p>

<div class="Tweet-metadata dateline"><a target="_blank"><time class="dt-updated" datetime="2018-04-24T20:05:50+0000">4:05 PM &#8211; Apr 24, 2018</time></a></div>
<ul class="Tweet-actions Tweet-action--newsActions" role="menu">
<li class="Tweet-action Tweet-action--newsAction">
<div class="Icon Icon--heartEdge TweetAction-icon" role="img"></div>
<p><a title="Like" target="_blank"><span class="TweetAction-stat">77.5K</span></a></li>
<li class="Tweet-action Tweet-action--newsAction">
<div class="Icon Icon--replyEdge TweetAction-icon" role="img"></div>
<p><a title="View the conversation on Twitter" target="_blank"><span class="TweetAction-stat">48.6K people are talking about this</span></a></li>
</ul>
</div>
</blockquote>
</div>
<div class="tweet-InformationCircle--bottom tweet-InformationCircle"><a title="Twitter Ads info and privacy" target="_blank"><span class="u-hiddenVisually">Twitter Ads info and privacy</span></a></div>
</div>
<div class="resize-sensor">
<div class="resize-sensor-expand">
<div></div>
</div>
<div class="resize-sensor-shrink">
<div></div>
</div>
</div>
</div>
</div>
<div class="canvas-tweet canvas-atom Ov(a) W(100%)">
<div class="SandboxRoot env-bp-350">
<div id="twitter-widget-1" class="EmbeddedTweet EmbeddedTweet--edge js-clickToOpenTarget tweet-InformationCircle-widgetParent" lang="en">
<div class="EmbeddedTweet-tweet">
<blockquote class="Tweet h-entry js-tweetIdInfo subject expanded" cite="https://twitter.com/MeekMill/status/988871671565008896">
<div class="Tweet-header"><a target="_blank"><img class="Avatar Avatar--edge" src="https://s0.wp.com/wp-content/themes/vip/plugins/lazy-load-0.7/images/1x1.trans.gif" alt data-lazy-src="https://pbs.twimg.com/profile_images/646884416304713728/jrqMaIdO_normal.jpg"><noscript><img class="Avatar Avatar--edge" src="https://pbs.twimg.com/profile_images/646884416304713728/jrqMaIdO_normal.jpg" alt="" /></noscript></a></p>
<div class="TweetAuthor js-inViewportScribingTarget">
<div class="TweetAuthor-nameScreenNameContainer"><span class="TweetAuthor-decoratedName"><span class="TweetAuthor-name Identity-name customisable-highlight" title="Meek Mill">Meek Mill</span></span></p>
<div class="Icon Icon--verified " title="Verified Account" role="img"></div>
<p><span class="TweetAuthor-decoratedName"><span class="TweetAuthor-verifiedBadge"><b class="u-hiddenVisually"><img src="https://s0.wp.com/wp-content/themes/vip/plugins/lazy-load-0.7/images/1x1.trans.gif" alt="✔" class="wp-smiley" style="height:1em;max-height:1em;" data-lazy-src="https://s0.wp.com/wp-content/mu-plugins/wpcom-smileys/twemoji/2/72x72/2714.png"><noscript><img src="https://s0.wp.com/wp-content/mu-plugins/wpcom-smileys/twemoji/2/72x72/2714.png" alt="✔" class="wp-smiley" style="height:1em;max-height:1em;" /></noscript></b></span></span><span class="TweetAuthor-screenName Identity-screenName" dir="ltr" title="@MeekMill">@MeekMill</span></div>
</div>
<div class="Tweet-brand">
<div class="Icon Icon--twitter " title="View on Twitter" role="presentation"></div>
</div>
</div>
<div class="Tweet-body e-entry-content">
<div class="u-hiddenVisually js-inViewportScribingTarget"></div>
<p class="Tweet-text e-entry-title" dir="ltr" lang="en">To the Philly District Attorney’s office, I’m grateful for your commitment to justice. I understand that many people of color across the country don’t have that luxury and I plan to use my platform to shine a light on those issues.</p>
<div class="Tweet-metadata dateline"><a target="_blank"><time class="dt-updated" datetime="2018-04-24T20:05:53+0000">4:05 PM &#8211; Apr 24, 2018</time></a></div>
<ul class="Tweet-actions Tweet-action--newsActions" role="menu">
<li class="Tweet-action Tweet-action--newsAction">
<div class="Icon Icon--heartEdge TweetAction-icon" role="img"></div>
<p><a title="Like" target="_blank"><span class="TweetAction-stat">33.2K</span></a></li>
<li class="Tweet-action Tweet-action--newsAction">
<div class="Icon Icon--replyEdge TweetAction-icon" role="img"></div>
<p><a title="View the conversation on Twitter" target="_blank"><span class="TweetAction-stat">18.2K people are talking about this</span></a></li>
</ul>
</div>
</blockquote>
</div>
<div class="tweet-InformationCircle--bottom tweet-InformationCircle"><a title="Twitter Ads info and privacy" target="_blank"><span class="u-hiddenVisually">Twitter Ads info and privacy</span></a></div>
</div>
<div class="resize-sensor">
<div class="resize-sensor-expand">
<div></div>
</div>
<div class="resize-sensor-shrink">
<div></div>
</div>
</div>
</div>
</div>
<div class="canvas-tweet canvas-atom Ov(a) W(100%)">
<div class="SandboxRoot env-bp-350">
<div id="twitter-widget-2" class="EmbeddedTweet EmbeddedTweet--edge js-clickToOpenTarget tweet-InformationCircle-widgetParent" lang="en">
<div class="EmbeddedTweet-tweet">
<blockquote class="Tweet h-entry js-tweetIdInfo subject expanded" cite="https://twitter.com/MeekMill/status/988871793032118272">
<div class="Tweet-header"><a target="_blank"><img class="Avatar Avatar--edge" src="https://s0.wp.com/wp-content/themes/vip/plugins/lazy-load-0.7/images/1x1.trans.gif" alt data-lazy-src="https://pbs.twimg.com/profile_images/646884416304713728/jrqMaIdO_normal.jpg"><noscript><img class="Avatar Avatar--edge" src="https://pbs.twimg.com/profile_images/646884416304713728/jrqMaIdO_normal.jpg" alt="" /></noscript></a></p>
<div class="TweetAuthor js-inViewportScribingTarget">
<div class="TweetAuthor-nameScreenNameContainer"><span class="TweetAuthor-decoratedName"><span class="TweetAuthor-name Identity-name customisable-highlight" title="Meek Mill">Meek Mill</span></span></p>
<div class="Icon Icon--verified " title="Verified Account" role="img"></div>
<p><span class="TweetAuthor-decoratedName"><span class="TweetAuthor-verifiedBadge"><b class="u-hiddenVisually"><img src="https://s0.wp.com/wp-content/themes/vip/plugins/lazy-load-0.7/images/1x1.trans.gif" alt="✔" class="wp-smiley" style="height:1em;max-height:1em;" data-lazy-src="https://s0.wp.com/wp-content/mu-plugins/wpcom-smileys/twemoji/2/72x72/2714.png"><noscript><img src="https://s0.wp.com/wp-content/mu-plugins/wpcom-smileys/twemoji/2/72x72/2714.png" alt="✔" class="wp-smiley" style="height:1em;max-height:1em;" /></noscript></b></span></span><span class="TweetAuthor-screenName Identity-screenName" dir="ltr" title="@MeekMill">@MeekMill</span></div>
</div>
<div class="Tweet-brand">
<div class="Icon Icon--twitter " title="View on Twitter" role="presentation"></div>
</div>
</div>
<div class="Tweet-body e-entry-content">
<div class="u-hiddenVisually js-inViewportScribingTarget"></div>
<p class="Tweet-text e-entry-title" dir="ltr" lang="en">In the meantime, I plan to work closely with my legal team to overturn this unwarranted conviction and look forward to reuniting with my family and resuming my music career.</p>
<div class="Tweet-metadata dateline"><a target="_blank"><time class="dt-updated" datetime="2018-04-24T20:06:22+0000">4:06 PM &#8211; Apr 24, 2018</time></a></div>
<ul class="Tweet-actions Tweet-action--newsActions" role="menu">
<li class="Tweet-action Tweet-action--newsAction">
<div class="Icon Icon--heartEdge TweetAction-icon" role="img"></div>
<p><a title="Like" target="_blank"><span class="TweetAction-stat">27.9K</span></a></li>
<li class="Tweet-action Tweet-action--newsAction">
<div class="Icon Icon--replyEdge TweetAction-icon" role="img"></div>
<p><a title="View the conversation on Twitter" target="_blank"><span class="TweetAction-stat">15.1K people are talking about this</span></a></li>
</ul>
</div>
</blockquote>
</div>
<div class="tweet-InformationCircle--bottom tweet-InformationCircle"><a title="Twitter Ads info and privacy" target="_blank"><span class="u-hiddenVisually">Twitter Ads info and privacy</span></a></div>
</div>
<div class="resize-sensor">
<div class="resize-sensor-expand">
<div></div>
</div>
<div class="resize-sensor-shrink">
<div></div>
</div>
</div>
</div>
</div>
<p class="canvas-atom canvas-text Mb(1.0em) Mb(0)--sm Mt(0.8em)--sm" style="margin:0 0 1em;">The Pennsylvania Supreme Court’s decision to release Williams comes on the heels of Judge Genece Brinkley <a href="https://www.spin.com/2018/04/meek-mill-bail-denied-genece-brinkley/" target="_blank" rel="nofollow noopener" target="_blank">denying his bail last week</a>, despite prosecutors asking her to toss the conviction.</p>
<p class="canvas-atom canvas-text Mb(1.0em) Mb(0)--sm Mt(0.8em)--sm">The rapper was sentenced to two to four years in prison in November for charges from two arrests earlier in the year. One was for a fight and another was for popping wheelies on a dirt bike. Williams was on probation from a 2008 gun and drug case, which he then violated with these charges and a failed drug test.</p>
<p class="canvas-atom canvas-text Mb(1.0em) Mb(0)--sm Mt(0.8em)--sm" style="margin:0 0 1em;">Williams’ sentencing led many to voice their support, both in person and on social media. November’s #Rally4Meek in Philadelphia saw protesters <a href="https://www.huffingtonpost.com/entry/meek-mill-philadelphia-rally_us_5a0ad981e4b00a6eece3fe1c" target="_blank" rel="nofollow noopener" target="_blank">marching through the streets, chanting “Free Meek Mill”</a> and rapping his song “Dreams and Nightmares.”</p>
<p class="canvas-atom canvas-text Mb(1.0em) Mb(0)--sm Mt(0.8em)--sm">Many on social media expressed their excitement for Williams’ release:</p>
		<form id="wpcom-iframe-form-2b671862ce291d0c3cdbcdeb2c03e288-5ae02921cc172" target="wpcom-iframe-2b671862ce291d0c3cdbcdeb2c03e288-5ae02921cc172" method="post" action="//wpcomwidgets.com/?wpcom_origin=https%3A%2F%2Fionechicagodefender.wordpress.com" style="display: none">
							<input type="hidden" name="width" value="300" />
							<input type="hidden" name="height" value="926" />
							<input type="hidden" name="frameborder" value="0" />
							<input type="hidden" name="style" value="" />
							<input type="hidden" name="class" value="canvas-instagram W(100%) Trsp(opacity) Trsdu(.42s) canvas-atom" />
							<input type="hidden" name="scrolling" value="no" />
							<input type="hidden" name="webkitallowfullscreen" value="" />
							<input type="hidden" name="mozallowfullscreen" value="" />
							<input type="hidden" name="allowfullscreen" value="" />
							<input type="hidden" name="resize" value="0" />
							<input type="hidden" name="replace_attributes" value="1" />
							<input type="hidden" name="fallback" value="&lt;p class=&quot;protected-embed-fallback&quot;&gt;This embed is invalid&lt;/p&gt;" />
							<input type="hidden" name="_data" value="PGlmcmFtZSBjbGFzcz0iY2FudmFzLWluc3RhZ3JhbSBXKDEwMCUpIFRyc3Aob3BhY2l0eSkgVHJzZHUoLjQycykgY2FudmFzLWF0b20iIHNyYz0iaHR0cHM6Ly9zLnlpbWcuY29tL29zL3ljL2h0bWwvZW1iZWQtaWZyYW1lLW1pbi4yZDc2MjFlMi5odG1sIiB3aWR0aD0iMzAwIiBoZWlnaHQ9IjkyNiIgZnJhbWVib3JkZXI9IjAiIHNjcm9sbGluZz0ibm8iIGRhdGEtdHlwZT0iaW5zdGFncmFtLWlmcmFtZSIgZGF0YS1tY2UtZnJhZ21lbnQ9IjEiIGFsbG93ZnVsbHNjcmVlbj0iIiByZXNpemU9IjAiIHJlcGxhY2VfYXR0cmlidXRlcz0iMSI+PC9pZnJhbWU+,8a22d5363e8d37ea3d904c8f7619b2178a2d58b3" />
							<input type="hidden" name="_tag" value="protected-iframe" />
							<input type="hidden" name="_hash" value="2b671862ce291d0c3cdbcdeb2c03e288" />
					</form>
		
				<iframe
						name="wpcom-iframe-2b671862ce291d0c3cdbcdeb2c03e288-5ae02921cc172"
			id="wpcom-iframe-2b671862ce291d0c3cdbcdeb2c03e288-5ae02921cc172"
			frameborder="0"
			scrolling="no"
			width="300" 			height="926" 			webkitallowfullscreen mozallowfullscreen allowfullscreen			class="wpcom-protected-iframe canvas-instagram W(100%) Trsp(opacity) Trsdu(.42s) canvas-atom"
		></iframe>
		
		<script type="text/javascript">
		( function() {
			var func = function() {
				var iframe_form = document.getElementById('wpcom-iframe-form-2b671862ce291d0c3cdbcdeb2c03e288-5ae02921cc172');
				var iframe = document.getElementById('wpcom-iframe-2b671862ce291d0c3cdbcdeb2c03e288-5ae02921cc172');
				if ( iframe_form && iframe ) {
					iframe_form.submit();
					iframe.onload = function() {
						iframe.contentWindow.postMessage( {
							'msg_type': 'poll_size',
							'frame_id': 'wpcom-iframe-2b671862ce291d0c3cdbcdeb2c03e288-5ae02921cc172'
						}, window.location.protocol + '//wpcomwidgets.com' );
					}
				}

				// Autosize iframe
				var funcSizeResponse = function( e ) {
					var origin = document.createElement( 'a' );
					origin.href = e.origin;

					// Verify message origin
					if ( 'wpcomwidgets.com' !== origin.host )
						return;

					// Verify message is in a format we expect
					if ( 'object' !== typeof e.data || undefined === e.data.msg_type )
						return;

					switch ( e.data.msg_type ) {
						case 'poll_size:response':
							var iframe = document.getElementById( e.data._request.frame_id );

							if ( iframe && '' === iframe.width )
								iframe.width = '100%';
							if ( iframe && '' === iframe.height )
								iframe.height = parseInt( e.data.height );

							return;
						default:
							return;
					}
				}

				if ( 'function' === typeof window.addEventListener ) {
					window.addEventListener( 'message', funcSizeResponse, false );
				} else if ( 'function' === typeof window.attachEvent ) {
					window.attachEvent( 'onmessage', funcSizeResponse );
				}
			}
			if (document.readyState === 'complete') { func.apply(); /* compat for infinite scroll */ }
			else if ( document.addEventListener ) { document.addEventListener( 'readystatechange', function(){ 
if (document.readyState === 'complete') { 
func.apply(); 
} 
},  false ); }
			else if ( document.attachEvent ) { document.attachEvent( 'onreadystatechange', func ); }
		} )();
		</script>
		
<div class="ione-widget-container ione-widget-ionead">		<div id="ad-in-post-content-203348-native" data-ad-id="in-post-content-203348-native" class="ad">
					<div id="div-gpt-in-post-content-203348-native" class="gpt-ad">
			<script type="text/javascript">
				window.ioneAds.defineSlot( {"name":"in-post-content-203348-native","path":"\/4052\/thechicagodefender\/desktop","sizes":[[1,1]],"div":"div-gpt-in-post-content-203348-native","targets":{"pos":"native","sz":"1x1"},"event_render":null,"event_refresh":null,"refresh_interval":null} );
			</script>
		</div>
				</div>
		</div>
<div class="canvas-tweet canvas-atom Ov(a) W(100%)">
<div class="SandboxRoot env-bp-350">
<div id="twitter-widget-3" class="EmbeddedTweet EmbeddedTweet--edge js-clickToOpenTarget tweet-InformationCircle-widgetParent" lang="en">
<div class="EmbeddedTweet-tweet">
<blockquote class="Tweet h-entry js-tweetIdInfo subject expanded" cite="https://twitter.com/RealLifeKaz/status/988872411910111234">
<div class="Tweet-header"><a target="_blank"><img class="Avatar Avatar--edge" src="https://s0.wp.com/wp-content/themes/vip/plugins/lazy-load-0.7/images/1x1.trans.gif" alt data-lazy-src="https://pbs.twimg.com/profile_images/977488716028669952/3u-avQtC_normal.jpg"><noscript><img class="Avatar Avatar--edge" src="https://pbs.twimg.com/profile_images/977488716028669952/3u-avQtC_normal.jpg" alt="" /></noscript></a></p>
<div class="TweetAuthor js-inViewportScribingTarget">
<div class="TweetAuthor-nameScreenNameContainer"><span class="TweetAuthor-decoratedName"><span class="TweetAuthor-name Identity-name customisable-highlight" title="Kazeem Famuyide">Kazeem Famuyide</span></span></p>
<div class="Icon Icon--verified " title="Verified Account" role="img"></div>
<p><span class="TweetAuthor-decoratedName"><span class="TweetAuthor-verifiedBadge"><b class="u-hiddenVisually"><img src="https://s0.wp.com/wp-content/themes/vip/plugins/lazy-load-0.7/images/1x1.trans.gif" alt="✔" class="wp-smiley" style="height:1em;max-height:1em;" data-lazy-src="https://s0.wp.com/wp-content/mu-plugins/wpcom-smileys/twemoji/2/72x72/2714.png"><noscript><img src="https://s0.wp.com/wp-content/mu-plugins/wpcom-smileys/twemoji/2/72x72/2714.png" alt="✔" class="wp-smiley" style="height:1em;max-height:1em;" /></noscript></b></span></span><span class="TweetAuthor-screenName Identity-screenName" dir="ltr" title="@RealLifeKaz">@RealLifeKaz</span></div>
</div>
<div class="Tweet-brand">
<div class="Icon Icon--twitter " title="View on Twitter" role="presentation"></div>
</div>
</div>
<div class="Tweet-body e-entry-content">
<div class="u-hiddenVisually js-inViewportScribingTarget"></div>
<p class="Tweet-text e-entry-title" dir="ltr" lang="en">WOW. <a target="_blank"><span class="PrettyLink-prefix">@</span><span class="PrettyLink-value">MeekMill</span></a> welcome home.</p>
<div class="Tweet-metadata dateline"><a target="_blank"><time class="dt-updated" datetime="2018-04-24T20:08:50+0000">4:08 PM &#8211; Apr 24, 2018</time></a></div>
<ul class="Tweet-actions Tweet-action--newsActions" role="menu">
<li class="Tweet-action Tweet-action--newsAction">
<div class="Icon Icon--heartEdge TweetAction-icon" role="img"></div>
<p><a title="Like" target="_blank"><span class="TweetAction-stat">46</span></a></li>
<li class="Tweet-action Tweet-action--newsAction">
<div class="Icon Icon--replyEdge TweetAction-icon" role="img"></div>
<p><a title="View the conversation on Twitter" target="_blank"><span class="TweetAction-stat">24 people are talking about this</span></a></li>
</ul>
</div>
</blockquote>
</div>
<div class="tweet-InformationCircle--bottom tweet-InformationCircle"><a title="Twitter Ads info and privacy" target="_blank"><span class="u-hiddenVisually">Twitter Ads info and privacy</span></a></div>
</div>
<div class="resize-sensor">
<div class="resize-sensor-expand">
<div></div>
</div>
<div class="resize-sensor-shrink">
<div></div>
</div>
</div>
</div>
</div>
<div class="canvas-tweet canvas-atom Ov(a) W(100%)">
<div class="SandboxRoot env-bp-350">
<div id="twitter-widget-4" class="EmbeddedTweet EmbeddedTweet--edge EmbeddedTweet--mediaForward media-forward js-clickToOpenTarget js-tweetIdInfo tweet-InformationCircle-widgetParent" lang="en">
<article class="MediaCard

           MediaCard--mediaForward

           cards-multimedia

           customisable-border" dir="ltr"></p>
<div class="MediaCard-media">
<div class="MediaCard-widthConstraint js-cspForcedStyle">
<div class="MediaCard-mediaContainer js-cspForcedStyle">
<div class="NaturalImage-ctaOverlay PlayButton PlayButton--centered">
<div class="Icon Icon--playCircle " title="Play Media" role="img"></div>
</div>
<p><a target="_blank"><img class="NaturalImage-image" src="https://s0.wp.com/wp-content/themes/vip/plugins/lazy-load-0.7/images/1x1.trans.gif" alt data-lazy-src="https://pbs.twimg.com/ext_tw_video_thumb/988871306631315456/pu/img/elWQgVPkNEGcIWdn?format=jpg&amp;name=small"><noscript><img class="NaturalImage-image" src="https://pbs.twimg.com/ext_tw_video_thumb/988871306631315456/pu/img/elWQgVPkNEGcIWdn?format=jpg&amp;name=small" alt="" /></noscript></a></div>
</div>
</div>
</article>
<div class="EmbeddedTweet-tweet">
<blockquote class="Tweet h-entry js-tweetIdInfo subject expanded" cite="https://twitter.com/JClarkNBCS/status/988871367075430400">
<div class="Tweet-header"><a target="_blank"><img class="Avatar Avatar--edge" src="https://s0.wp.com/wp-content/themes/vip/plugins/lazy-load-0.7/images/1x1.trans.gif" alt data-lazy-src="https://pbs.twimg.com/profile_images/920113209708892160/d93cXP8Q_normal.jpg"><noscript><img class="Avatar Avatar--edge" src="https://pbs.twimg.com/profile_images/920113209708892160/d93cXP8Q_normal.jpg" alt="" /></noscript></a></p>
<div class="TweetAuthor js-inViewportScribingTarget">
<div class="TweetAuthor-nameScreenNameContainer"><span class="TweetAuthor-decoratedName"><span class="TweetAuthor-name Identity-name customisable-highlight" title="John Clark">John Clark</span></span></p>
<div class="Icon Icon--verified " title="Verified Account" role="img"></div>
<p><span class="TweetAuthor-decoratedName"><span class="TweetAuthor-verifiedBadge"><b class="u-hiddenVisually"><img src="https://s0.wp.com/wp-content/themes/vip/plugins/lazy-load-0.7/images/1x1.trans.gif" alt="✔" class="wp-smiley" style="height:1em;max-height:1em;" data-lazy-src="https://s0.wp.com/wp-content/mu-plugins/wpcom-smileys/twemoji/2/72x72/2714.png"><noscript><img src="https://s0.wp.com/wp-content/mu-plugins/wpcom-smileys/twemoji/2/72x72/2714.png" alt="✔" class="wp-smiley" style="height:1em;max-height:1em;" /></noscript></b></span></span><span class="TweetAuthor-screenName Identity-screenName" dir="ltr" title="@JClarkNBCS">@JClarkNBCS</span></div>
</div>
<div class="Tweet-brand">
<div class="Icon Icon--twitter " title="View on Twitter" role="presentation"></div>
</div>
</div>
<div class="Tweet-body e-entry-content">
<div class="u-hiddenVisually js-inViewportScribingTarget"></div>
<p class="Tweet-text e-entry-title" dir="ltr" lang="en">Eagles reaction to <a target="_blank"><span class="PrettyLink-prefix">@</span><span class="PrettyLink-value">MeekMill</span></a> being realeased from prison. Maybe. Probably<img class="Emoji Emoji--forText" title="Fire" src="https://s0.wp.com/wp-content/themes/vip/plugins/lazy-load-0.7/images/1x1.trans.gif" alt="&#x1f525;" data-lazy-src="https://abs.twimg.com/emoji/v2/72x72/1f525.png"><noscript><img class="Emoji Emoji--forText" title="Fire" src="https://abs.twimg.com/emoji/v2/72x72/1f525.png" alt="&#x1f525;" /></noscript><img class="Emoji Emoji--forText" title="Fire" src="https://s0.wp.com/wp-content/themes/vip/plugins/lazy-load-0.7/images/1x1.trans.gif" alt="&#x1f525;" data-lazy-src="https://abs.twimg.com/emoji/v2/72x72/1f525.png"><noscript><img class="Emoji Emoji--forText" title="Fire" src="https://abs.twimg.com/emoji/v2/72x72/1f525.png" alt="&#x1f525;" /></noscript><a rel="tag" target="_blank"><span class="PrettyLink-prefix">#</span><span class="PrettyLink-value">DreamsAndNightmares</span></a></p>
<div class="Tweet-metadata dateline"><a target="_blank"><time class="dt-updated" datetime="2018-04-24T20:04:40+0000">4:04 PM &#8211; Apr 24, 2018</time></a></div>
<ul class="Tweet-actions Tweet-action--newsActions" role="menu">
<li class="Tweet-action Tweet-action--newsAction">
<div class="Icon Icon--heartEdge TweetAction-icon" role="img"></div>
<p><a title="Like" target="_blank"><span class="TweetAction-stat">576</span></a></li>
<li class="Tweet-action Tweet-action--newsAction">
<div class="Icon Icon--replyEdge TweetAction-icon" role="img"></div>
<p><a title="View the conversation on Twitter" target="_blank"><span class="TweetAction-stat">272 people are talking about this</span></a></li>
</ul>
</div>
</blockquote>
</div>
<div class="tweet-InformationCircle--top tweet-InformationCircle--topEdge tweet-InformationCircle"><a title="Twitter Ads info and privacy" target="_blank"><span class="u-hiddenVisually">Twitter Ads info and privacy</span></a></div>
</div>
<div class="resize-sensor">
<div class="resize-sensor-expand">
<div></div>
</div>
<div class="resize-sensor-shrink">
<div></div>
</div>
</div>
</div>
</div>
<div class="canvas-tweet canvas-atom Ov(a) W(100%)">
<div class="SandboxRoot env-bp-350">
<div id="twitter-widget-5" class="EmbeddedTweet EmbeddedTweet--edge EmbeddedTweet--mediaForward media-forward js-clickToOpenTarget js-tweetIdInfo tweet-InformationCircle-widgetParent" lang="en">
<article class="MediaCard

           MediaCard--mediaForward

           cards-multimedia

           customisable-border" dir="ltr"></p>
<div class="MediaCard-media">
<div class="MediaCard-widthConstraint js-cspForcedStyle">
<div class="MediaCard-mediaContainer js-cspForcedStyle">
<div class="NaturalImage-ctaOverlay PlayButton PlayButton--centered">
<div class="Icon Icon--playCircle " title="Play Media" role="img"></div>
</div>
<p><a target="_blank"><img class="NaturalImage-image" src="https://s0.wp.com/wp-content/themes/vip/plugins/lazy-load-0.7/images/1x1.trans.gif" alt data-lazy-src="https://pbs.twimg.com/tweet_video_thumb/Dbkt0FRVMAAJzxk?format=jpg&amp;name=small"><noscript><img class="NaturalImage-image" src="https://pbs.twimg.com/tweet_video_thumb/Dbkt0FRVMAAJzxk?format=jpg&amp;name=small" alt="" /></noscript></a></div>
</div>
</div>
</article>
<div class="EmbeddedTweet-tweet">
<blockquote class="Tweet h-entry js-tweetIdInfo subject expanded" cite="https://twitter.com/04SEASONS/status/988871973454405632">
<div class="Tweet-header"><a target="_blank"><img class="Avatar Avatar--edge" src="https://s0.wp.com/wp-content/themes/vip/plugins/lazy-load-0.7/images/1x1.trans.gif" alt data-lazy-src="https://pbs.twimg.com/profile_images/988873041563344898/QrUAK4L3_normal.jpg"><noscript><img class="Avatar Avatar--edge" src="https://pbs.twimg.com/profile_images/988873041563344898/QrUAK4L3_normal.jpg" alt="" /></noscript></a></p>
<div class="TweetAuthor js-inViewportScribingTarget">
<div class="TweetAuthor-nameScreenNameContainer"><span class="TweetAuthor-decoratedName"><span class="TweetAuthor-name Identity-name customisable-highlight" title="SEASONS">SEASONS</span></span><span class="TweetAuthor-screenName Identity-screenName" dir="ltr" title="@04SEASONS">@04SEASONS</span></div>
</div>
<div class="Tweet-brand">
<div class="Icon Icon--twitter " title="View on Twitter" role="presentation"></div>
</div>
</div>
<div class="Tweet-body e-entry-content">
<div class="u-hiddenVisually js-inViewportScribingTarget"></div>
<p class="Tweet-text e-entry-title" dir="ltr" lang="en">BREAKING: MEEK MILL IS OFFICIALLY FREE FROM PRISON <img class="Emoji Emoji--forText" title="Person raising both hands in celebration" src="https://s0.wp.com/wp-content/themes/vip/plugins/lazy-load-0.7/images/1x1.trans.gif" alt="&#x1f64c;" data-lazy-src="https://abs.twimg.com/emoji/v2/72x72/1f64c.png"><noscript><img class="Emoji Emoji--forText" title="Person raising both hands in celebration" src="https://abs.twimg.com/emoji/v2/72x72/1f64c.png" alt="&#x1f64c;" /></noscript></p>
<div class="Tweet-metadata dateline"><a target="_blank"><time class="dt-updated" datetime="2018-04-24T20:07:05+0000">4:07 PM &#8211; Apr 24, 2018</time></a></div>
<ul class="Tweet-actions Tweet-action--newsActions" role="menu">
<li class="Tweet-action Tweet-action--newsAction">
<div class="Icon Icon--heartEdge TweetAction-icon" role="img"></div>
<p><a title="Like" target="_blank"><span class="TweetAction-stat">75</span></a></li>
<li class="Tweet-action Tweet-action--newsAction">
<div class="Icon Icon--replyEdge TweetAction-icon" role="img"></div>
<p><a title="View the conversation on Twitter" target="_blank"><span class="TweetAction-stat">27 people are talking about this</span></a></li>
</ul>
</div>
</blockquote>
</div>
<div class="tweet-InformationCircle--top tweet-InformationCircle--topEdge tweet-InformationCircle"><a title="Twitter Ads info and privacy" target="_blank"><span class="u-hiddenVisually">Twitter Ads info and privacy</span></a></div>
</div>
<div class="resize-sensor">
<div class="resize-sensor-expand">
<div></div>
</div>
<div class="resize-sensor-shrink">
<div></div>
</div>
</div>
</div>
</div>
<div class="canvas-tweet canvas-atom Ov(a) W(100%)">
<div class="SandboxRoot env-bp-350">
<div id="twitter-widget-6" class="EmbeddedTweet EmbeddedTweet--edge EmbeddedTweet--mediaForward media-forward js-clickToOpenTarget js-tweetIdInfo tweet-InformationCircle-widgetParent" lang="en">
<article class="MediaCard

           MediaCard--mediaForward

           cards-multimedia

           customisable-border" dir="ltr"></p>
<div class="MediaCard-media">
<div class="MediaCard-widthConstraint js-cspForcedStyle">
<div class="MediaCard-mediaContainer js-cspForcedStyle">
<div class="NaturalImage-ctaOverlay PlayButton PlayButton--centered">
<div class="Icon Icon--playCircle " title="Play Media" role="img"></div>
</div>
<p><a target="_blank"><img class="NaturalImage-image" src="https://s0.wp.com/wp-content/themes/vip/plugins/lazy-load-0.7/images/1x1.trans.gif" alt data-lazy-src="https://pbs.twimg.com/ext_tw_video_thumb/988870571982110720/pu/img/ZXA9mPpHqgGc6oQm?format=jpg&amp;name=small"><noscript><img class="NaturalImage-image" src="https://pbs.twimg.com/ext_tw_video_thumb/988870571982110720/pu/img/ZXA9mPpHqgGc6oQm?format=jpg&amp;name=small" alt="" /></noscript></a></div>
</div>
</div>
</article>
<div class="EmbeddedTweet-tweet">
<blockquote class="Tweet h-entry js-tweetIdInfo subject expanded" cite="https://twitter.com/lilsnupeforlife/status/988870700520951815">
<div class="Tweet-header"><a target="_blank"><img class="Avatar Avatar--edge" src="https://s0.wp.com/wp-content/themes/vip/plugins/lazy-load-0.7/images/1x1.trans.gif" alt data-lazy-src="https://pbs.twimg.com/profile_images/966882684487127040/wgFNi05h_normal.jpg"><noscript><img class="Avatar Avatar--edge" src="https://pbs.twimg.com/profile_images/966882684487127040/wgFNi05h_normal.jpg" alt="" /></noscript></a></p>
<div class="TweetAuthor js-inViewportScribingTarget">
<div class="TweetAuthor-nameScreenNameContainer"><span class="TweetAuthor-decoratedName"><span class="TweetAuthor-name Identity-name customisable-highlight" title="Lilsnupe">Lilsnupe</span></span><span class="TweetAuthor-screenName Identity-screenName" dir="ltr" title="@lilsnupeforlife">@lilsnupeforlife</span></div>
</div>
<div class="Tweet-brand">
<div class="Icon Icon--twitter " title="View on Twitter" role="presentation"></div>
</div>
</div>
<div class="Tweet-body e-entry-content">
<div class="u-hiddenVisually js-inViewportScribingTarget"></div>
<p class="Tweet-text e-entry-title" dir="ltr" lang="en">YES MY BROTHER IS FREE <img class="Emoji Emoji--forText" title="Fire" src="https://s0.wp.com/wp-content/themes/vip/plugins/lazy-load-0.7/images/1x1.trans.gif" alt="&#x1f525;" data-lazy-src="https://abs.twimg.com/emoji/v2/72x72/1f525.png"><noscript><img class="Emoji Emoji--forText" title="Fire" src="https://abs.twimg.com/emoji/v2/72x72/1f525.png" alt="&#x1f525;" /></noscript><img class="Emoji Emoji--forText" title="Person with folded hands (dark skin tone)" src="https://s0.wp.com/wp-content/themes/vip/plugins/lazy-load-0.7/images/1x1.trans.gif" alt="&#x1f64f;&#x1f3ff;" data-lazy-src="https://abs.twimg.com/emoji/v2/72x72/1f64f-1f3ff.png"><noscript><img class="Emoji Emoji--forText" title="Person with folded hands (dark skin tone)" src="https://abs.twimg.com/emoji/v2/72x72/1f64f-1f3ff.png" alt="&#x1f64f;&#x1f3ff;" /></noscript><img class="Emoji Emoji--forText" title="Speaking head in silhouette" src="https://s0.wp.com/wp-content/themes/vip/plugins/lazy-load-0.7/images/1x1.trans.gif" alt="&#x1f5e3;" data-lazy-src="https://abs.twimg.com/emoji/v2/72x72/1f5e3.png"><noscript><img class="Emoji Emoji--forText" title="Speaking head in silhouette" src="https://abs.twimg.com/emoji/v2/72x72/1f5e3.png" alt="&#x1f5e3;" /></noscript><a target="_blank"><span class="PrettyLink-prefix">@</span><span class="PrettyLink-value">MeekMill</span></a> <a rel="tag" target="_blank"><span class="PrettyLink-prefix">#</span><span class="PrettyLink-value">RIPSNUPE</span></a></p>
<div class="Tweet-metadata dateline"><a target="_blank"><time class="dt-updated" datetime="2018-04-24T20:02:01+0000">4:02 PM &#8211; Apr 24, 2018</time></a> · <a target="_blank">Brockton, MA</a></div>
<ul class="Tweet-actions Tweet-action--newsActions" role="menu">
<li class="Tweet-action Tweet-action--newsAction">
<div class="Icon Icon--heartEdge TweetAction-icon" role="img"></div>
<p><a title="Like" target="_blank"><span class="TweetAction-stat">28</span></a></li>
<li class="Tweet-action Tweet-action--newsAction">
<div class="Icon Icon--replyEdge TweetAction-icon" role="img"></div>
<p><a title="View the conversation on Twitter" target="_blank"><span class="TweetAction-stat">24 people are talking about this</span></a></li>
</ul>
</div>
</blockquote>
</div>
<div class="tweet-InformationCircle--top tweet-InformationCircle--topEdge tweet-InformationCircle"><a title="Twitter Ads info and privacy" target="_blank"><span class="u-hiddenVisually">Twitter Ads info and privacy</span></a></div>
</div>
<div class="resize-sensor">
<div class="resize-sensor-expand">
<div></div>
</div>
<div class="resize-sensor-shrink">
<div></div>
</div>
</div>
</div>
</div>
<p class="canvas-atom canvas-text Mb(1.0em) Mb(0)--sm Mt(0.8em)--sm" style="margin:0 0 1em;">Joe Tacopina, Williams’ lawyer, said he was <a href="http://6abc.com/meek-mill-to-be-released-from-prison/3387105/" target="_blank" rel="nofollow noopener" target="_blank">“thrilled” that the court released Williams on bail</a>.</p>
<p class="canvas-atom canvas-text Mb(1.0em) Mb(0)--sm Mt(0.8em)--sm">“As we have said all along, Meek was unjustly convicted and should not have spent a single day in jail,” Tacopina said, according to 6ABC. “We are also pleased that the Pennsylvania Supreme Court has noted that Judge Brinkley may opt to remove herself from presiding over any further proceedings in Meek’s case in the interests of justice. Meek is excited to be reunited with his family, and we, along with Meek, intend to continue to shine the light on a justice system in need of reform to prevent any other citizen from being put through what Meek has endured.”</p>
<p class="canvas-atom canvas-text Mb(1.0em) Mb(0)--sm Mt(0.8em)--sm">Williams’ legal team had filed a petition in February that focused on the credibility of a police officer involved in the rapper’s arrest in 2007. The Philadelphia District Attorney’s Office filed a response to that petition, saying “there is a strong showing of likelihood of the Petitioner’s conviction being reversed (in whole or in part).”</p>

<p class="canvas-atom canvas-text Mb(1.0em) Mb(0)--sm Mt(0.8em)--sm" style="margin:0 0 1em;">According to Pitchfork, the D.A.’s office “<a href="https://pitchfork.com/news/meek-mill-to-be-released-from-prison-report/" target="_blank" rel="nofollow noopener" target="_blank">cited testimony from an officer whose prior testimony against corrupt cops resulted in hundreds of conviction reversals</a>.”</p>
<ul class="canvas-list List(d)">
<li>This article originally appeared on <a href="https://www.huffingtonpost.com/entry/meek-mill-release-prison_us_5adf8afde4b07560f396482f?ncid=edlinkushpmg00000313" target="_blank" target="_blank">HuffPost</a>.</li>
</ul>
<p class="canvas-atom canvas-text Mb(1.0em) Mb(0)--sm Mt(0.8em)--sm" style="margin:0 0 1em;"><strong>Related Video: Meek Mill Speaks Out from Prison</strong></p>
<div class="react-placeholder W(100%) Pos(r) Mt(0.8em)--sm Mb(12px) Mt(12px)">		<form id="wpcom-iframe-form-c2144e12e32511a45e9305f265c054f8-5ae02921cc36d" target="wpcom-iframe-c2144e12e32511a45e9305f265c054f8-5ae02921cc36d" method="post" action="//wpcomwidgets.com/?wpcom_origin=https%3A%2F%2Fionechicagodefender.wordpress.com" style="display: none">
							<input type="hidden" name="width" value="100%" />
							<input type="hidden" name="height" value="100%" />
							<input type="hidden" name="frameborder" value="0" />
							<input type="hidden" name="style" value="" />
							<input type="hidden" name="class" value="Bdw(0) My(0) Mx(a) D(b) W(100%) H(100%) StretchedBox canvas-atom Mt(14px)--sm Mb(0)--sm" />
							<input type="hidden" name="scrolling" value="yes" />
							<input type="hidden" name="webkitallowfullscreen" value="" />
							<input type="hidden" name="mozallowfullscreen" value="" />
							<input type="hidden" name="allowfullscreen" value="" />
							<input type="hidden" name="resize" value="0" />
							<input type="hidden" name="replace_attributes" value="1" />
							<input type="hidden" name="fallback" value="&lt;p class=&quot;protected-embed-fallback&quot;&gt;This embed is invalid&lt;/p&gt;" />
							<input type="hidden" name="_data" value="PGlmcmFtZSBjbGFzcz0iQmR3KDApIE15KDApIE14KGEpIEQoYikgVygxMDAlKSBIKDEwMCUpIFN0cmV0Y2hlZEJveCBjYW52YXMtYXRvbSBNdCgxNHB4KS0tc20gTWIoMCktLXNtIiBzcmM9Imh0dHBzOi8vdmlldy55YWhvby5jb20vZW1iZWQ/aWQ9NjEwOTgwMjMmYW1wO3R5cGU9Y2xpcCZhbXA7YXV0b3BsYXk9MCZhbXA7bXV0ZT0wJmFtcDt1dG1fc291cmNlPXlhaG9vJmFtcDt1dG1fbWVkaXVtPXJlZmVycmFsJmFtcDt1dG1fY2FtcGFpZ249YXJ0aWNsZSIgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZnJhbWVib3JkZXI9IjAiIHNjcm9sbGluZz0ieWVzIiBkYXRhLXR5cGU9ImlmcmFtZSIgZGF0YS1tY2UtZnJhZ21lbnQ9IjEiIGFsbG93ZnVsbHNjcmVlbj0iIiByZXNpemU9IjAiIHJlcGxhY2VfYXR0cmlidXRlcz0iMSI+PC9pZnJhbWU+,af591597844f5faedad419bbb450642f29394c45" />
							<input type="hidden" name="_tag" value="protected-iframe" />
							<input type="hidden" name="_hash" value="c2144e12e32511a45e9305f265c054f8" />
					</form>
		
				<iframe
						name="wpcom-iframe-c2144e12e32511a45e9305f265c054f8-5ae02921cc36d"
			id="wpcom-iframe-c2144e12e32511a45e9305f265c054f8-5ae02921cc36d"
			frameborder="0"
			scrolling="yes"
			width="100%" 			height="100%" 			webkitallowfullscreen mozallowfullscreen allowfullscreen			class="wpcom-protected-iframe Bdw(0) My(0) Mx(a) D(b) W(100%) H(100%) StretchedBox canvas-atom Mt(14px)--sm Mb(0)--sm"
		></iframe>
		
		<script type="text/javascript">
		( function() {
			var func = function() {
				var iframe_form = document.getElementById('wpcom-iframe-form-c2144e12e32511a45e9305f265c054f8-5ae02921cc36d');
				var iframe = document.getElementById('wpcom-iframe-c2144e12e32511a45e9305f265c054f8-5ae02921cc36d');
				if ( iframe_form && iframe ) {
					iframe_form.submit();
					iframe.onload = function() {
						iframe.contentWindow.postMessage( {
							'msg_type': 'poll_size',
							'frame_id': 'wpcom-iframe-c2144e12e32511a45e9305f265c054f8-5ae02921cc36d'
						}, window.location.protocol + '//wpcomwidgets.com' );
					}
				}

				// Autosize iframe
				var funcSizeResponse = function( e ) {
					var origin = document.createElement( 'a' );
					origin.href = e.origin;

					// Verify message origin
					if ( 'wpcomwidgets.com' !== origin.host )
						return;

					// Verify message is in a format we expect
					if ( 'object' !== typeof e.data || undefined === e.data.msg_type )
						return;

					switch ( e.data.msg_type ) {
						case 'poll_size:response':
							var iframe = document.getElementById( e.data._request.frame_id );

							if ( iframe && '' === iframe.width )
								iframe.width = '100%';
							if ( iframe && '' === iframe.height )
								iframe.height = parseInt( e.data.height );

							return;
						default:
							return;
					}
				}

				if ( 'function' === typeof window.addEventListener ) {
					window.addEventListener( 'message', funcSizeResponse, false );
				} else if ( 'function' === typeof window.attachEvent ) {
					window.attachEvent( 'onmessage', funcSizeResponse );
				}
			}
			if (document.readyState === 'complete') { func.apply(); /* compat for infinite scroll */ }
			else if ( document.addEventListener ) { document.addEventListener( 'readystatechange', function(){ 
if (document.readyState === 'complete') { 
func.apply(); 
} 
},  false ); }
			else if ( document.attachEvent ) { document.attachEvent( 'onreadystatechange', func ); }
		} )();
		</script>
		</div>
<p class="canvas-atom canvas-text Mb(1.0em) Mb(0)--sm Mt(0.8em)--sm" style="margin:0 0 1em;"><em>Watch <a href="https://view.yahoo.com/browse/tv/genre/news-and-information?utm_campaign=tout&amp;utm_medium=referral&amp;utm_source=yahoo/" target="_blank" target="_blank">news</a>, TV and more on <a href="https://view.yahoo.com/?utm_campaign=tout&amp;utm_medium=referral&amp;utm_source=yahoo" target="_blank" target="_blank">Yahoo View</a>.</em></p>
</div>
</article>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<p class="page-numbers"></p>
						<div class="post-sharing bottom-sharing">
							
<!-- Go to www.addthis.com/dashboard to customize your tools -->
<div class="addthis_responsive_sharing addthis-large-layout"></div>

						</div>

						
	<div class="ione-tab author-more-tab">

		<ul class="ione-tab__tabs">
							<li class="-active">
					<a href="#more-by-content" class="more-by-link">More By
						<span class="name">Roz Edward</span></a>
				</li>
								</ul>

		<div class="ione-tab__content">
							<div id="more-by-content" class="more-by-content">
					<ul class="more-posts">
													<li class="more-by-post">
								<a href="https://chicagodefender.com/2018/04/24/watch-white-woman-tells-cop-shut-the-fk-up-and-she-isnt-shot/">Watch: White Woman Tells Cop ‘Shut The F**k Up’ And She Isn’t Shot</a>
							</li>
													<li class="more-by-post">
								<a href="https://chicagodefender.com/2018/04/24/meek-mill-released-from-prison-looks-forward-to-resuming-music-career/">Meek Mill released from prison, looks forward to resuming music career</a>
							</li>
													<li class="more-by-post">
								<a href="https://chicagodefender.com/2018/04/24/florida-teen-with-racist-promposal-sign-is-now-crying-white-tears/">Florida Teen With Racist ‘Promposal’ Sign Is Now Crying White Tears</a>
							</li>
											</ul>
				</div>
					</div>
	</div><!-- .post-author__tabs --><div class="gallery-intro post-content__pulled-left">Also On The Chicago Defender:</div><div class="ione-gallery post-content__pulled-left ">
	<div class="ione-gallery-inner">

		<div class="ione-gallery__mobile-header">
			<a href="https://chicagodefender.com/">
				<img srcset="https://ionechicagodefender.files.wordpress.com/2016/09/chicagodefender-nav-logo.png?w=211&amp;resize=9999%2C50&amp;quality=80&amp;strip=all 1x, https://ionechicagodefender.files.wordpress.com/2016/09/chicagodefender-nav-logo.png?w=211&amp;resize=9999%2C100&amp;quality=80&amp;strip=all 2x" class="navbar-logo" />			</a>
			<i class="icon-close ione-gallery__close-mobile"></i>
		</div>
		<div class="ione-gallery__mobile-featured">
			<img width="900" height="473" src="https://s0.wp.com/wp-content/themes/vip/plugins/lazy-load-0.7/images/1x1.trans.gif" class="attachment-ione3_gallery size-ione3_gallery wp-post-image" alt data-attachment-id="202813" data-permalink="https://chicagodefender.com/?attachment_id=202813" data-orig-file="https://ionechicagodefender.files.wordpress.com/2018/04/group-shot-e1524073336390.jpg?quality=80&amp;strip=all" data-orig-size="4782,2514" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;5.6&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;Canon EOS Rebel T6&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;946685159&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;53&quot;,&quot;iso&quot;:&quot;800&quot;,&quot;shutter_speed&quot;:&quot;0.005&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="Group Shot" data-image-description data-medium-file="https://ionechicagodefender.files.wordpress.com/2018/04/group-shot-e1524073336390.jpg?quality=80&amp;strip=all&amp;w=300" data-large-file="https://ionechicagodefender.files.wordpress.com/2018/04/group-shot-e1524073336390.jpg?quality=80&amp;strip=all&amp;w=1024" data-lazy-src="https://ionechicagodefender.files.wordpress.com/2018/04/group-shot-e1524073336390.jpg?quality=80&amp;strip=all&amp;w=900" data-lazy-srcset="https://ionechicagodefender.files.wordpress.com/2018/04/group-shot-e1524073336390.jpg?quality=80&amp;strip=all&amp;w=900 900w, https://ionechicagodefender.files.wordpress.com/2018/04/group-shot-e1524073336390.jpg?quality=80&amp;strip=all&amp;w=1800 1800w, https://ionechicagodefender.files.wordpress.com/2018/04/group-shot-e1524073336390.jpg?quality=80&amp;strip=all&amp;w=150 150w, https://ionechicagodefender.files.wordpress.com/2018/04/group-shot-e1524073336390.jpg?quality=80&amp;strip=all&amp;w=300 300w, https://ionechicagodefender.files.wordpress.com/2018/04/group-shot-e1524073336390.jpg?quality=80&amp;strip=all&amp;w=768 768w, https://ionechicagodefender.files.wordpress.com/2018/04/group-shot-e1524073336390.jpg?quality=80&amp;strip=all&amp;w=1024 1024w" data-lazy-sizes="(max-width: 900px) 100vw, 900px"><noscript><img width="900" height="473" src="https://ionechicagodefender.files.wordpress.com/2018/04/group-shot-e1524073336390.jpg?quality=80&amp;strip=all&amp;w=900" class="attachment-ione3_gallery size-ione3_gallery wp-post-image" alt="" srcset="https://ionechicagodefender.files.wordpress.com/2018/04/group-shot-e1524073336390.jpg?quality=80&amp;strip=all&amp;w=900 900w, https://ionechicagodefender.files.wordpress.com/2018/04/group-shot-e1524073336390.jpg?quality=80&amp;strip=all&amp;w=1800 1800w, https://ionechicagodefender.files.wordpress.com/2018/04/group-shot-e1524073336390.jpg?quality=80&amp;strip=all&amp;w=150 150w, https://ionechicagodefender.files.wordpress.com/2018/04/group-shot-e1524073336390.jpg?quality=80&amp;strip=all&amp;w=300 300w, https://ionechicagodefender.files.wordpress.com/2018/04/group-shot-e1524073336390.jpg?quality=80&amp;strip=all&amp;w=768 768w, https://ionechicagodefender.files.wordpress.com/2018/04/group-shot-e1524073336390.jpg?quality=80&amp;strip=all&amp;w=1024 1024w" sizes="(max-width: 900px) 100vw, 900px" data-attachment-id="202813" data-permalink="https://chicagodefender.com/?attachment_id=202813" data-orig-file="https://ionechicagodefender.files.wordpress.com/2018/04/group-shot-e1524073336390.jpg?quality=80&amp;strip=all" data-orig-size="4782,2514" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;5.6&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;Canon EOS Rebel T6&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;946685159&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;53&quot;,&quot;iso&quot;:&quot;800&quot;,&quot;shutter_speed&quot;:&quot;0.005&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="Group Shot" data-image-description="" data-medium-file="https://ionechicagodefender.files.wordpress.com/2018/04/group-shot-e1524073336390.jpg?quality=80&amp;strip=all&amp;w=300" data-large-file="https://ionechicagodefender.files.wordpress.com/2018/04/group-shot-e1524073336390.jpg?quality=80&amp;strip=all&amp;w=1024" /></noscript>		</div>

		
		<a href="#" class="ione-gallery__mobile-launcher">
			<h2 class="ione-gallery__main-title">Chicago is new fashion mecca for ethnic wear</h2>
			<div class="video-poster">
				<span><i class="icon-photos"><span>34 photos</span></i> <span>Launch gallery</span></span>
			</div>
		</a>

		<div class="ione-gallery__ad-banner">
					<div id="ad-gallery-long-banner203348" data-ad-id="gallery-long-banner203348" class="ad">
					<div id="div-gpt-gallery-long-banner203348" class="gpt-ad">
			<script type="text/javascript">
				window.ioneAds.defineSlot( {"name":"gallery-long-banner203348","path":"\/4052\/thechicagodefender\/desktop","sizes":[[728,90]],"div":"div-gpt-gallery-long-banner203348","targets":{"pos":"gallery","sz":"728x90"},"event_render":"refresh-div-gpt-gallery-long-banner203348","event_refresh":null,"refresh_interval":null} );
			</script>
		</div>
				</div>
				</div>


		<div class="ione-gallery__images">

			<h2 class="ione-gallery__main-title"><a href="https://chicagodefender.com/playlist/202851/">Chicago is new fashion mecca for ethnic wear</a></h2>

			<div class="ione-gallery__slideshow"
				data-title="Chicago is new fashion mecca for ethnic wear"
				data-description=""
				data-prev-gallery="https://chicagodefender.com/2018/04/24/florida-teen-with-racist-promposal-sign-is-now-crying-white-tears/"
				data-next-gallery="https://chicagodefender.com/playlist/heres-every-breathtaking-editorial-featuring-muslim-model-halima-aden/"
				data-count="34"
				data-gallery-url="https://chicagodefender.com/2018/04/24/meek-mill-released-from-prison-looks-forward-to-resuming-music-career/"
				data-gallery-id="202851"
				data-categories="Fashion"
				data-tags=""
				data-author="redward298"
				>
									<div
						id="gallery-1"
						data-title="IMG_0535 (2)"
						data-description=""
						data-url="https://chicagodefender.com/playlist/202851/#gallery-1"
						data-image-id="202852"
						data-has-ad=""
						>
							<h3 class="ione-listicle__title">
								1. IMG_0535 (2)							</h3>
						<img data-lazy="https://ionechicagodefender.files.wordpress.com/2018/04/img_0535-2.jpg?quality=80&#038;strip=all&#038;w=253" alt="" class="">												<span class="photo-count">
							1 of 34						</span>
						<div class="listicle-description">
							
													</div>
											</div>
									<div
						id="gallery-2"
						data-title="IMG_0534 (2)"
						data-description=""
						data-url="https://chicagodefender.com/playlist/202851/#gallery-2"
						data-image-id="202853"
						data-has-ad=""
						>
							<h3 class="ione-listicle__title">
								2. IMG_0534 (2)							</h3>
						<img data-lazy="https://ionechicagodefender.files.wordpress.com/2018/04/img_0534-2.jpg?quality=80&#038;strip=all&#038;w=448" alt="" class="">												<span class="photo-count">
							2 of 34						</span>
						<div class="listicle-description">
							
													</div>
											</div>
									<div
						id="gallery-3"
						data-title="IMG_0536 (2)"
						data-description=""
						data-url="https://chicagodefender.com/playlist/202851/#gallery-3"
						data-image-id="202854"
						data-has-ad=""
						>
							<h3 class="ione-listicle__title">
								3. IMG_0536 (2)							</h3>
						<img data-lazy="https://ionechicagodefender.files.wordpress.com/2018/04/img_0536-2.jpg?quality=80&#038;strip=all&#038;w=313" alt="" class="">												<span class="photo-count">
							3 of 34						</span>
						<div class="listicle-description">
							
													</div>
											</div>
									<div
						id="gallery-4"
						data-title="IMG_0540 (2)"
						data-description=""
						data-url="https://chicagodefender.com/playlist/202851/#gallery-4"
						data-image-id="202855"
						data-has-ad=""
						>
							<h3 class="ione-listicle__title">
								4. IMG_0540 (2)							</h3>
						<img data-lazy="https://ionechicagodefender.files.wordpress.com/2018/04/img_0540-2.jpg?quality=80&#038;strip=all&#038;w=356" alt="" class="">												<span class="photo-count">
							4 of 34						</span>
						<div class="listicle-description">
							
													</div>
											</div>
									<div
						id="gallery-5"
						data-title="IMG_0541 (2)"
						data-description=""
						data-url="https://chicagodefender.com/playlist/202851/#gallery-5"
						data-image-id="202856"
						data-has-ad="1"
						>
							<h3 class="ione-listicle__title">
								5. IMG_0541 (2)							</h3>
						<img data-lazy="https://ionechicagodefender.files.wordpress.com/2018/04/img_0541-2.jpg?quality=80&#038;strip=all&#038;w=436" alt="" class="">												<span class="photo-count">
							5 of 34						</span>
						<div class="listicle-description">
							
													</div>
											</div>
									<div
						id="gallery-6"
						data-title="IMG_0542 (2)"
						data-description=""
						data-url="https://chicagodefender.com/playlist/202851/#gallery-6"
						data-image-id="202857"
						data-has-ad=""
						>
							<h3 class="ione-listicle__title">
								6. IMG_0542 (2)							</h3>
						<img data-lazy="https://ionechicagodefender.files.wordpress.com/2018/04/img_0542-2.jpg?quality=80&#038;strip=all&#038;w=352" alt="" class="">												<span class="photo-count">
							6 of 34						</span>
						<div class="listicle-description">
							
													</div>
											</div>
									<div
						id="gallery-7"
						data-title="IMG_0563 (2)"
						data-description=""
						data-url="https://chicagodefender.com/playlist/202851/#gallery-7"
						data-image-id="202858"
						data-has-ad=""
						>
							<h3 class="ione-listicle__title">
								7. IMG_0563 (2)							</h3>
						<img data-lazy="https://ionechicagodefender.files.wordpress.com/2018/04/img_0563-2.jpg?quality=80&#038;strip=all&#038;w=271" alt="" class="">												<span class="photo-count">
							7 of 34						</span>
						<div class="listicle-description">
							
													</div>
											</div>
									<div
						id="gallery-8"
						data-title="IMG_0560 (2)"
						data-description=""
						data-url="https://chicagodefender.com/playlist/202851/#gallery-8"
						data-image-id="202859"
						data-has-ad=""
						>
							<h3 class="ione-listicle__title">
								8. IMG_0560 (2)							</h3>
						<img data-lazy="https://ionechicagodefender.files.wordpress.com/2018/04/img_0560-2.jpg?quality=80&#038;strip=all&#038;w=311" alt="" class="">												<span class="photo-count">
							8 of 34						</span>
						<div class="listicle-description">
							
													</div>
											</div>
									<div
						id="gallery-9"
						data-title="IMG_0559 (2)"
						data-description=""
						data-url="https://chicagodefender.com/playlist/202851/#gallery-9"
						data-image-id="202860"
						data-has-ad=""
						>
							<h3 class="ione-listicle__title">
								9. IMG_0559 (2)							</h3>
						<img data-lazy="https://ionechicagodefender.files.wordpress.com/2018/04/img_0559-2.jpg?quality=80&#038;strip=all&#038;w=315" alt="" class="">												<span class="photo-count">
							9 of 34						</span>
						<div class="listicle-description">
							
													</div>
											</div>
									<div
						id="gallery-10"
						data-title="IMG_0556 (2)"
						data-description=""
						data-url="https://chicagodefender.com/playlist/202851/#gallery-10"
						data-image-id="202861"
						data-has-ad="1"
						>
							<h3 class="ione-listicle__title">
								10. IMG_0556 (2)							</h3>
						<img data-lazy="https://ionechicagodefender.files.wordpress.com/2018/04/img_0556-2.jpg?quality=80&#038;strip=all&#038;w=306" alt="" class="">												<span class="photo-count">
							10 of 34						</span>
						<div class="listicle-description">
							
													</div>
											</div>
									<div
						id="gallery-11"
						data-title="IMG_0555 (2)"
						data-description=""
						data-url="https://chicagodefender.com/playlist/202851/#gallery-11"
						data-image-id="202862"
						data-has-ad=""
						>
							<h3 class="ione-listicle__title">
								11. IMG_0555 (2)							</h3>
						<img data-lazy="https://ionechicagodefender.files.wordpress.com/2018/04/img_0555-2.jpg?quality=80&#038;strip=all&#038;w=315" alt="" class="">												<span class="photo-count">
							11 of 34						</span>
						<div class="listicle-description">
							
													</div>
											</div>
									<div
						id="gallery-12"
						data-title="IMG_0543 (2)"
						data-description=""
						data-url="https://chicagodefender.com/playlist/202851/#gallery-12"
						data-image-id="202863"
						data-has-ad=""
						>
							<h3 class="ione-listicle__title">
								12. IMG_0543 (2)							</h3>
						<img data-lazy="https://ionechicagodefender.files.wordpress.com/2018/04/img_0543-2.jpg?quality=80&#038;strip=all&#038;w=532" alt="" class="">												<span class="photo-count">
							12 of 34						</span>
						<div class="listicle-description">
							
													</div>
											</div>
									<div
						id="gallery-13"
						data-title="IMG_0566 (2)"
						data-description=""
						data-url="https://chicagodefender.com/playlist/202851/#gallery-13"
						data-image-id="202864"
						data-has-ad=""
						>
							<h3 class="ione-listicle__title">
								13. IMG_0566 (2)							</h3>
						<img data-lazy="https://ionechicagodefender.files.wordpress.com/2018/04/img_0566-2.jpg?quality=80&#038;strip=all&#038;w=241" alt="" class="">												<span class="photo-count">
							13 of 34						</span>
						<div class="listicle-description">
							
													</div>
											</div>
									<div
						id="gallery-14"
						data-title="IMG_0569 (2)"
						data-description=""
						data-url="https://chicagodefender.com/playlist/202851/#gallery-14"
						data-image-id="202865"
						data-has-ad=""
						>
							<h3 class="ione-listicle__title">
								14. IMG_0569 (2)							</h3>
						<img data-lazy="https://ionechicagodefender.files.wordpress.com/2018/04/img_0569-2.jpg?quality=80&#038;strip=all&#038;w=208" alt="" class="">												<span class="photo-count">
							14 of 34						</span>
						<div class="listicle-description">
							
													</div>
											</div>
									<div
						id="gallery-15"
						data-title="IMG_0571 (2)"
						data-description=""
						data-url="https://chicagodefender.com/playlist/202851/#gallery-15"
						data-image-id="202866"
						data-has-ad="1"
						>
							<h3 class="ione-listicle__title">
								15. IMG_0571 (2)							</h3>
						<img data-lazy="https://ionechicagodefender.files.wordpress.com/2018/04/img_0571-2.jpg?quality=80&#038;strip=all&#038;w=200" alt="" class="">												<span class="photo-count">
							15 of 34						</span>
						<div class="listicle-description">
							
													</div>
											</div>
									<div
						id="gallery-16"
						data-title="IMG_0574 (2)"
						data-description=""
						data-url="https://chicagodefender.com/playlist/202851/#gallery-16"
						data-image-id="202867"
						data-has-ad=""
						>
							<h3 class="ione-listicle__title">
								16. IMG_0574 (2)							</h3>
						<img data-lazy="https://ionechicagodefender.files.wordpress.com/2018/04/img_0574-2.jpg?quality=80&#038;strip=all&#038;w=272" alt="" class="">												<span class="photo-count">
							16 of 34						</span>
						<div class="listicle-description">
							
													</div>
											</div>
									<div
						id="gallery-17"
						data-title="IMG_0575 (2)"
						data-description=""
						data-url="https://chicagodefender.com/playlist/202851/#gallery-17"
						data-image-id="202868"
						data-has-ad=""
						>
							<h3 class="ione-listicle__title">
								17. IMG_0575 (2)							</h3>
						<img data-lazy="https://ionechicagodefender.files.wordpress.com/2018/04/img_0575-2.jpg?quality=80&#038;strip=all&#038;w=526" alt="" class="">												<span class="photo-count">
							17 of 34						</span>
						<div class="listicle-description">
							
													</div>
											</div>
									<div
						id="gallery-18"
						data-title="IMG_0576 (2)"
						data-description=""
						data-url="https://chicagodefender.com/playlist/202851/#gallery-18"
						data-image-id="202869"
						data-has-ad=""
						>
							<h3 class="ione-listicle__title">
								18. IMG_0576 (2)							</h3>
						<img data-lazy="https://ionechicagodefender.files.wordpress.com/2018/04/img_0576-2.jpg?quality=80&#038;strip=all&#038;w=320" alt="" class="">												<span class="photo-count">
							18 of 34						</span>
						<div class="listicle-description">
							
													</div>
											</div>
									<div
						id="gallery-19"
						data-title="IMG_0577 (2)"
						data-description=""
						data-url="https://chicagodefender.com/playlist/202851/#gallery-19"
						data-image-id="202870"
						data-has-ad=""
						>
							<h3 class="ione-listicle__title">
								19. IMG_0577 (2)							</h3>
						<img data-lazy="https://ionechicagodefender.files.wordpress.com/2018/04/img_0577-2.jpg?quality=80&#038;strip=all&#038;w=265" alt="" class="">												<span class="photo-count">
							19 of 34						</span>
						<div class="listicle-description">
							
													</div>
											</div>
									<div
						id="gallery-20"
						data-title="IMG_0579 (2)"
						data-description=""
						data-url="https://chicagodefender.com/playlist/202851/#gallery-20"
						data-image-id="202871"
						data-has-ad="1"
						>
							<h3 class="ione-listicle__title">
								20. IMG_0579 (2)							</h3>
						<img data-lazy="https://ionechicagodefender.files.wordpress.com/2018/04/img_0579-2.jpg?quality=80&#038;strip=all&#038;w=260" alt="" class="">												<span class="photo-count">
							20 of 34						</span>
						<div class="listicle-description">
							
													</div>
											</div>
									<div
						id="gallery-21"
						data-title="IMG_0580 (2)"
						data-description=""
						data-url="https://chicagodefender.com/playlist/202851/#gallery-21"
						data-image-id="202872"
						data-has-ad=""
						>
							<h3 class="ione-listicle__title">
								21. IMG_0580 (2)							</h3>
						<img data-lazy="https://ionechicagodefender.files.wordpress.com/2018/04/img_0580-2.jpg?quality=80&#038;strip=all&#038;w=243" alt="" class="">												<span class="photo-count">
							21 of 34						</span>
						<div class="listicle-description">
							
													</div>
											</div>
									<div
						id="gallery-22"
						data-title="IMG_0581 (2)"
						data-description=""
						data-url="https://chicagodefender.com/playlist/202851/#gallery-22"
						data-image-id="202873"
						data-has-ad=""
						>
							<h3 class="ione-listicle__title">
								22. IMG_0581 (2)							</h3>
						<img data-lazy="https://ionechicagodefender.files.wordpress.com/2018/04/img_0581-2.jpg?quality=80&#038;strip=all&#038;w=251" alt="" class="">												<span class="photo-count">
							22 of 34						</span>
						<div class="listicle-description">
							
													</div>
											</div>
									<div
						id="gallery-23"
						data-title="IMG_0587 (2)"
						data-description=""
						data-url="https://chicagodefender.com/playlist/202851/#gallery-23"
						data-image-id="202874"
						data-has-ad=""
						>
							<h3 class="ione-listicle__title">
								23. IMG_0587 (2)							</h3>
						<img data-lazy="https://ionechicagodefender.files.wordpress.com/2018/04/img_0587-2.jpg?quality=80&#038;strip=all&#038;w=203" alt="" class="">												<span class="photo-count">
							23 of 34						</span>
						<div class="listicle-description">
							
													</div>
											</div>
									<div
						id="gallery-24"
						data-title="IMG_0589 (2)"
						data-description=""
						data-url="https://chicagodefender.com/playlist/202851/#gallery-24"
						data-image-id="202875"
						data-has-ad=""
						>
							<h3 class="ione-listicle__title">
								24. IMG_0589 (2)							</h3>
						<img data-lazy="https://ionechicagodefender.files.wordpress.com/2018/04/img_0589-2.jpg?quality=80&#038;strip=all&#038;w=297" alt="" class="">												<span class="photo-count">
							24 of 34						</span>
						<div class="listicle-description">
							
													</div>
											</div>
									<div
						id="gallery-25"
						data-title="IMG_0607"
						data-description=""
						data-url="https://chicagodefender.com/playlist/202851/#gallery-25"
						data-image-id="202876"
						data-has-ad="1"
						>
							<h3 class="ione-listicle__title">
								25. IMG_0607							</h3>
						<img data-lazy="https://ionechicagodefender.files.wordpress.com/2018/04/img_0607.jpg?quality=80&#038;strip=all&#038;w=400" alt="" class="">												<span class="photo-count">
							25 of 34						</span>
						<div class="listicle-description">
							
													</div>
											</div>
									<div
						id="gallery-26"
						data-title="IMG_0602 (2)"
						data-description=""
						data-url="https://chicagodefender.com/playlist/202851/#gallery-26"
						data-image-id="202877"
						data-has-ad=""
						>
							<h3 class="ione-listicle__title">
								26. IMG_0602 (2)							</h3>
						<img data-lazy="https://ionechicagodefender.files.wordpress.com/2018/04/img_0602-2.jpg?quality=80&#038;strip=all&#038;w=240" alt="" class="">												<span class="photo-count">
							26 of 34						</span>
						<div class="listicle-description">
							
													</div>
											</div>
									<div
						id="gallery-27"
						data-title="IMG_0601"
						data-description=""
						data-url="https://chicagodefender.com/playlist/202851/#gallery-27"
						data-image-id="202878"
						data-has-ad=""
						>
							<h3 class="ione-listicle__title">
								27. IMG_0601							</h3>
						<img data-lazy="https://ionechicagodefender.files.wordpress.com/2018/04/img_0601.jpg?quality=80&#038;strip=all&#038;w=400" alt="" class="">												<span class="photo-count">
							27 of 34						</span>
						<div class="listicle-description">
							
													</div>
											</div>
									<div
						id="gallery-28"
						data-title="IMG_0597 (2)"
						data-description=""
						data-url="https://chicagodefender.com/playlist/202851/#gallery-28"
						data-image-id="202879"
						data-has-ad=""
						>
							<h3 class="ione-listicle__title">
								28. IMG_0597 (2)							</h3>
						<img data-lazy="https://ionechicagodefender.files.wordpress.com/2018/04/img_0597-2.jpg?quality=80&#038;strip=all&#038;w=241" alt="" class="">												<span class="photo-count">
							28 of 34						</span>
						<div class="listicle-description">
							
													</div>
											</div>
									<div
						id="gallery-29"
						data-title="IMG_0595 (2)"
						data-description=""
						data-url="https://chicagodefender.com/playlist/202851/#gallery-29"
						data-image-id="202880"
						data-has-ad=""
						>
							<h3 class="ione-listicle__title">
								29. IMG_0595 (2)							</h3>
						<img data-lazy="https://ionechicagodefender.files.wordpress.com/2018/04/img_0595-2.jpg?quality=80&#038;strip=all&#038;w=268" alt="" class="">												<span class="photo-count">
							29 of 34						</span>
						<div class="listicle-description">
							
													</div>
											</div>
									<div
						id="gallery-30"
						data-title="IMG_0594 (2)"
						data-description=""
						data-url="https://chicagodefender.com/playlist/202851/#gallery-30"
						data-image-id="202881"
						data-has-ad="1"
						>
							<h3 class="ione-listicle__title">
								30. IMG_0594 (2)							</h3>
						<img data-lazy="https://ionechicagodefender.files.wordpress.com/2018/04/img_0594-2.jpg?quality=80&#038;strip=all&#038;w=278" alt="" class="">												<span class="photo-count">
							30 of 34						</span>
						<div class="listicle-description">
							
													</div>
											</div>
									<div
						id="gallery-31"
						data-title="IMG_0608 (2)"
						data-description=""
						data-url="https://chicagodefender.com/playlist/202851/#gallery-31"
						data-image-id="202882"
						data-has-ad=""
						>
							<h3 class="ione-listicle__title">
								31. IMG_0608 (2)							</h3>
						<img data-lazy="https://ionechicagodefender.files.wordpress.com/2018/04/img_0608-2.jpg?quality=80&#038;strip=all&#038;w=318" alt="" class="">												<span class="photo-count">
							31 of 34						</span>
						<div class="listicle-description">
							
													</div>
											</div>
									<div
						id="gallery-32"
						data-title="IMG_0560 (2)"
						data-description=""
						data-url="https://chicagodefender.com/playlist/202851/#gallery-32"
						data-image-id="202883"
						data-has-ad=""
						>
							<h3 class="ione-listicle__title">
								32. IMG_0560 (2)							</h3>
						<img data-lazy="https://ionechicagodefender.files.wordpress.com/2018/04/img_0560-21.jpg?quality=80&#038;strip=all&#038;w=311" alt="" class="">												<span class="photo-count">
							32 of 34						</span>
						<div class="listicle-description">
							
													</div>
											</div>
									<div
						id="gallery-33"
						data-title="IMG_0581 (2)"
						data-description=""
						data-url="https://chicagodefender.com/playlist/202851/#gallery-33"
						data-image-id="202884"
						data-has-ad=""
						>
							<h3 class="ione-listicle__title">
								33. IMG_0581 (2)							</h3>
						<img data-lazy="https://ionechicagodefender.files.wordpress.com/2018/04/img_0581-21.jpg?quality=80&#038;strip=all&#038;w=251" alt="" class="">												<span class="photo-count">
							33 of 34						</span>
						<div class="listicle-description">
							
													</div>
											</div>
									<div
						id="gallery-34"
						data-title="Group Shot"
						data-description=""
						data-url="https://chicagodefender.com/playlist/202851/#gallery-34"
						data-image-id="202885"
						data-has-ad=""
						>
							<h3 class="ione-listicle__title">
								34. Group Shot							</h3>
						<img data-lazy="https://ionechicagodefender.files.wordpress.com/2018/04/group-shot-e1524073336390.jpg?quality=80&#038;strip=all&#038;w=900" alt="" class="">												<span class="photo-count">
							34 of 34						</span>
						<div class="listicle-description">
							
													</div>
											</div>
							</div>
			<!-- .ione-gallery__slideshow -->

			<div class="in-gallery-ad" id="in-gallery-banner-ad">
				<button class="skip-ad"><i class="icon-close"></i></button>
				<button class="skip-ad text">Skip ad</button>
						<div id="ad-inner-gallery203348" data-ad-id="inner-gallery203348" class="ad">
					<div id="div-gpt-inner-gallery203348" class="gpt-ad">
			<script type="text/javascript">
				window.ioneAds.defineSlot( {"name":"inner-gallery203348","path":"\/4052\/thechicagodefender\/desktop","sizes":[[300,250]],"div":"div-gpt-inner-gallery203348","targets":{"pos":"inner-gallery","sz":"300x250"},"event_render":"refresh-div-gpt-inner-gallery203348","event_refresh":null,"refresh_interval":null} );
			</script>
		</div>
				</div>
					</div>

		</div>
		<!-- .ione-gallery__images -->

		<div class="ione-gallery__sidebar">
			<a href="https://chicagodefender.com/"><img srcset="https://ionechicagodefender.files.wordpress.com/2016/09/chicagodefender-nav-logo.png?w=211&amp;resize=9999%2C50&amp;quality=80&amp;strip=all 1x, https://ionechicagodefender.files.wordpress.com/2016/09/chicagodefender-nav-logo.png?w=211&amp;resize=9999%2C100&amp;quality=80&amp;strip=all 2x" class="navbar-logo" /></a>
			<i class="icon-close ione-gallery__close"></i>
			<span class="ione-gallery__return">
				Continue reading Meek Mill released from prison, looks forward to resuming music career			</span>
			<div class="ione-gallery_desc-wrapper">
				<h3 class="ione-gallery__title">Chicago is new fashion mecca for ethnic wear</h3>
				<p class="ione-gallery__description"></p>
				<!-- addthis -->
				<div id="ione-gallery-share" class="addthis_32x32_style addthis_default_style">
					<a class="addthis_button_facebook" addthis:url="https://chicagodefender.com/2018/04/24/meek-mill-released-from-prison-looks-forward-to-resuming-music-career/" addthis:title="Chicago is new fashion mecca for ethnic wear"><i class="icon-facebook"></i></a>
					<a class="addthis_button_twitter" addthis:url="https://chicagodefender.com/2018/04/24/meek-mill-released-from-prison-looks-forward-to-resuming-music-career/" addthis:title="Chicago is new fashion mecca for ethnic wear"><i class="icon-twitter"></i></a>
					<a class="addthis_button_email" addthis:url="https://chicagodefender.com/2018/04/24/meek-mill-released-from-prison-looks-forward-to-resuming-music-career/" addthis:title="Chicago is new fashion mecca for ethnic wear"><i class="icon-email"></i></a>
				</div>
			</div>

			<div class="ione-gallery__ad">
						<div id="ad-gallery203348" data-ad-id="gallery203348" class="ad">
					<div id="div-gpt-gallery203348" class="gpt-ad">
			<script type="text/javascript">
				window.ioneAds.defineSlot( {"name":"gallery203348","path":"\/4052\/thechicagodefender\/desktop","sizes":[[300,250]],"div":"div-gpt-gallery203348","targets":{"pos":"gallery","sz":"300x250"},"event_render":"refresh-div-gpt-gallery203348","event_refresh":null,"refresh_interval":null} );
			</script>
		</div>
				</div>
					</div>
		</div>
		<!-- .ione-gallery__sidebar -->
		<div class="ione-gallery__mobile-header">
			<a href="https://chicagodefender.com/"><img srcset="https://ionechicagodefender.files.wordpress.com/2016/09/chicagodefender-nav-logo.png?w=211&amp;resize=9999%2C50&amp;quality=80&amp;strip=all 1x, https://ionechicagodefender.files.wordpress.com/2016/09/chicagodefender-nav-logo.png?w=211&amp;resize=9999%2C100&amp;quality=80&amp;strip=all 2x" class="navbar-logo" /></a>
			<i class="icon-close ione-gallery__close-mobile"></i>
		</div>
	</div>
</div>
					</div>
					<!-- .post-content -->

					<a name="respond"></a>
<div class="post-comments ione-toggle" data-name="ione-comments-203348" data-class="post-comments__displayed">
	<div class="post-comments__title ione-toggle__trigger">
		<span><span class="fb-comments-count" data-href="https://chicagodefender.com/2018/04/24/meek-mill-released-from-prison-looks-forward-to-resuming-music-career/"></span> comments</span> – add yours
		<i class="icon-arrow-down"></i>
	</div>
	<div class="ione-toggle__content">
		<div id="comments" class="fb-comments" data-width="100%" data-href="https://chicagodefender.com/2018/04/24/meek-mill-released-from-prison-looks-forward-to-resuming-music-career/" data-numposts="5" data-colorscheme="light"></div>
	</div>
</div>
		<div id="zergnet-widget-58418"></div>
		<script language="javascript" type="text/javascript">
			(function() {
				if ( 'cpc' === ioneAdUtils.getUTM( 'utm_medium' ) ) {
					return;
				}
				var zergnet   = document.createElement('script');
				var znscr     = document.getElementsByTagName('script')[0];
				zergnet.type  = 'text/javascript';
				zergnet.async = true;
				zergnet.src   = (document.location.protocol == "https:" ? "https:" : "http:") + "\/\/www.zergnet.com\/zerg.js?id=58418";
				znscr.parentNode.insertBefore(zergnet, znscr);
			})();
		</script>
						</div>
				
				<div class="ad-single-side">
					<div class="static-ads">
							<div class="sidebar-non-ad above-first-ad">
								<div class="ione-widget-container ione-widget-image">		<div class="ione-widget-container ione-widget-image">
			<div class="module-container">
									<div class="module__title">This Week&#8217;s CD!</div>
				<a class="image-widget-image-link" href="https://issuu.com/chidefender/docs/chicagodefender_04.25.18" target="_blank" title="CD- 04-25-18"><img srcset="https://ionechicagodefender.files.wordpress.com/2018/04/cd-04-25_01.jpg?quality=80&#038;strip=all&#038;w=1024 400w, https://ionechicagodefender.files.wordpress.com/2018/04/cd-04-25_01.jpg?quality=80&#038;strip=all&#038;w=1024 700w, https://ionechicagodefender.files.wordpress.com/2018/04/cd-04-25_01.jpg?quality=80&#038;strip=all&#038;w=1024 900w" alt="" class="" width="1024" height="1224"></a>					<span class="image-widget-description">CD- 04-25-18</span> 			</div>
		</div> </div><div class="ione-widget-container ione-widget-image">		<div class="ione-widget-container ione-widget-image">
			<div class="module-container">
									<div class="module__title">Black Music Month Edition</div>
				<a class="image-widget-image-link" href="https://chicagodefender.com/chi-def-music-month-supplement/" target="_blank" title="Black Music Month Edition"><img srcset="https://ionechicagodefender.files.wordpress.com/2017/06/screen-shot-2017-06-22-at-2-18-43-pm.png?w=646&#038;quality=80&#038;strip=all 400w, https://ionechicagodefender.files.wordpress.com/2017/06/screen-shot-2017-06-22-at-2-18-43-pm.png?w=646&#038;quality=80&#038;strip=all 700w, https://ionechicagodefender.files.wordpress.com/2017/06/screen-shot-2017-06-22-at-2-18-43-pm.png?w=646&#038;quality=80&#038;strip=all 900w" alt="" class="" width="646" height="827"></a>			</div>
		</div> </div>							</div>


						<div class="sidebar-ad first-ad">
							<div class="ione-widget-container ione-widget-ionead">		<div id="ad-sidebar1" data-ad-id="sidebar1" class="ad">
					<div id="div-gpt-sidebar1" class="gpt-ad">
			<script type="text/javascript">
				window.ioneAds.defineSlot( {"name":"sidebar1","path":"\/4052\/thechicagodefender\/desktop","sizes":[[300,250],[300,600],[300,1050]],"div":"div-gpt-sidebar1","targets":{"pos":"1","sz":"300x250,300x600,300x1050"},"event_render":null,"event_refresh":null,"refresh_interval":null} );
			</script>
		</div>
				</div>
		</div>						</div>
							<div class="sidebar-non-ad above-second-ad">
								<div class="ione-widget-container ione-widget-trending"><div class="widget widget-trending">
	<span class="widget-title">Trending</span>
	<ul>
						<li class="video-poster in-pictures has-post-thumbnail post-27552 post type-post status-publish format-standard hentry category-c105-health tag-headaches">
					<a href="https://chicagodefender.com/2013/09/20/headache-locations-what-do-they-mean/" class="post-link">
						<div class="poster">
							<img srcset="https://ionechicagodefender.files.wordpress.com/2013/09/images_headache.jpg?quality=80&#038;strip=all&#038;w=100&#038;h=100&#038;crop=1&#038;resize=100%2C100 400w, https://ionechicagodefender.files.wordpress.com/2013/09/images_headache.jpg?quality=80&#038;strip=all&#038;w=200&#038;h=200&#038;crop=1&#038;resize=200%2C200 700w, https://ionechicagodefender.files.wordpress.com/2013/09/images_headache.jpg?quality=80&#038;strip=all&#038;w=300&#038;h=265&#038;crop=1&#038;resize=300%2C300 900w" alt="Headache" class="" width="100" height="100">						</div>
												<div class="post-title">Headache Locations: What Do They Mean?</div>
					</a>
				</li>
								<li class="video-poster in-pictures has-post-thumbnail post-199389 post type-post status-publish format-standard hentry category-c100-entertainment category-homepage-lead category-newsletter">
					<a href="https://chicagodefender.com/2018/03/23/chicago-actress-monique-dushone-dies-at-49-video/" class="post-link">
						<div class="poster">
							<img srcset="https://ionechicagodefender.files.wordpress.com/2018/03/monique-dushon.jpg?quality=80&#038;strip=all&#038;w=100&#038;h=100&#038;crop=1&#038;resize=100%2C100 400w, https://ionechicagodefender.files.wordpress.com/2018/03/monique-dushon.jpg?quality=80&#038;strip=all&#038;w=200&#038;h=166&#038;crop=1&#038;resize=200%2C200 700w, https://ionechicagodefender.files.wordpress.com/2018/03/monique-dushon.jpg?quality=80&#038;strip=all&#038;w=300&#038;h=166&#038;crop=1&#038;resize=300%2C300 900w" alt="" class="" width="100" height="100">						</div>
												<div class="post-title">&#8216;Chicago&#8217; actress Dushon Monique Brown dies at 49 [VIDEO]</div>
					</a>
				</li>
								<li class="video-poster in-pictures has-post-thumbnail post-176307 post type-post status-publish format-standard hentry category-c99-culture tag-better-sex">
					<a href="https://chicagodefender.com/2017/01/25/girl-get-yours-what-positions-are-best-for-female-orgasm-2/" class="post-link">
						<div class="poster">
							<img srcset="https://ionehellobeautiful.files.wordpress.com/2015/06/14340230580727-e1434023063164.jpg?quality=70&#038;strip=all&#038;w=100&#038;h=100&#038;crop=1 400w, https://ionehellobeautiful.files.wordpress.com/2015/06/14340230580727-e1434023063164.jpg?quality=70&#038;strip=all&#038;w=200&#038;h=200&#038;crop=1 700w, https://ionehellobeautiful.files.wordpress.com/2015/06/14340230580727-e1434023063164.jpg?quality=70&#038;strip=all&#038;w=300&#038;h=300&#038;crop=1 900w" class="" width="100" height="100"/>						</div>
												<div class="post-title">Girl Get Yours: What Positions Are Best For Female Orgasm?</div>
					</a>
				</li>
								<li class="video-poster in-pictures has-post-thumbnail post-199751 post type-post status-publish format-standard hentry category-homepage-lead category-nation category-news category-newsletter category-c149-politics">
					<a href="https://chicagodefender.com/2018/03/30/barack-obama-is-reportedly-returning-to-politics-2/" class="post-link">
						<div class="poster">
							<img srcset="https://ionechicagodefender.files.wordpress.com/2017/04/img_2983.jpeg?quality=80&#038;strip=all&#038;w=100&#038;h=100&#038;crop=1&#038;resize=100%2C100 400w, https://ionechicagodefender.files.wordpress.com/2017/04/img_2983.jpeg?quality=80&#038;strip=all&#038;w=200&#038;h=200&#038;crop=1&#038;resize=200%2C200 700w, https://ionechicagodefender.files.wordpress.com/2017/04/img_2983.jpeg?quality=80&#038;strip=all&#038;w=300&#038;h=300&#038;crop=1&#038;resize=300%2C300 900w" alt="" class="" width="100" height="100">						</div>
												<div class="post-title">Barack Obama is reportedly returning to politics</div>
					</a>
				</li>
								<li class="video-poster in-pictures has-post-thumbnail post-167233 post type-post status-publish format-standard hentry category-c100-entertainment category-c105-health category-c99-culture category-newsletter tag-aids tag-cure tag-fda tag-honduras tag-pharmaceutical tag-sebi">
					<a href="https://chicagodefender.com/2016/08/15/no-mainstream-farewell-for-dr-sebi/" class="post-link">
						<div class="poster">
							<img srcset="https://ionechicagodefender.files.wordpress.com/2016/08/dr-sebi-cures.jpg?quality=80&#038;strip=all&#038;w=100&#038;h=100&#038;crop=1&#038;resize=100%2C100 400w, https://ionechicagodefender.files.wordpress.com/2016/08/dr-sebi-cures.jpg?quality=80&#038;strip=all&#038;w=200&#038;h=200&#038;crop=1&#038;resize=200%2C200 700w, https://ionechicagodefender.files.wordpress.com/2016/08/dr-sebi-cures.jpg?quality=80&#038;strip=all&#038;w=300&#038;h=300&#038;crop=1&#038;resize=300%2C300 900w" alt="" class="" width="100" height="100">						</div>
												<div class="post-title">No Mainstream Farewell for Dr.Sebi</div>
					</a>
				</li>
								<li class="video-poster in-pictures has-post-thumbnail post-192908 post type-post status-publish format-standard hentry category-c100-entertainment">
					<a href="https://chicagodefender.com/2017/11/02/married-to-medicine-star-lisa-nicole-cloud-catches-husband-in-another-affair-audio-released/" class="post-link">
						<div class="poster">
							<img srcset="https://ionehellobeautiful.files.wordpress.com/2017/03/14819165086773.png?w=100&#038;h=100&#038;crop=1 400w, https://ionehellobeautiful.files.wordpress.com/2017/03/14819165086773.png?w=200&#038;h=200&#038;crop=1 700w, https://ionehellobeautiful.files.wordpress.com/2017/03/14819165086773.png?w=300&#038;h=300&#038;crop=1 900w" class="" width="100" height="100"/>						</div>
												<div class="post-title">‘Married To Medicine’ Star Lisa Nicole Cloud Catches Husband In Another Affair, Audio Released</div>
					</a>
				</li>
					</ul>
	<div class="social-footer">
		<p>Get Informed!</p>
				<!-- Go to www.addthis.com/dashboard to customize your tools -->
		<div class="addthis_custom_follow"></div>
	</div>
</div>
</div><div class="ione-widget-container ione-widget-social_conversion">
		<style type="text/css">
			#ione-social_conversion-15 .sailthru-signup-widget button {
				background: #ffffff;
				color: #000000;
			}

			#ione-social_conversion-15 .sc-wrapper {
				border: 1px solid #D3D3D3;
			}

			#ione-social_conversion-15 .sc-wrap img {
				max-width: 100%;
			}

			#ione-social_conversion-15 .sc-newsletter p,
			#ione-social_conversion-15 .sailthru-signup-widget label,
			#ione-social_conversion-15 .sailthru-add-subscriber-errors,
			#ione-social_conversion-15 .sc-share p {
				color: #ffffff;
			}

					</style>

		<div id="ione-social_conversion-15" class="sc-wrap disable-popup" style="padding: 20px; background-color: #D3D3D3;">
			<a class="sc-close" style="color: #ffffff;" rel="nofollow">&times;</a>

			<div class="social-conversion" style="text-align: center;">
				<img style="margin-bottom: 10px;" src="https://ionechicagodefender.files.wordpress.com/2016/09/chicagodefender-nav-logo.png" />				<div class="sc-newsletter">
					<p>Sign Up Now For The Chicago Defender Digital Daily Newsletter!</p><div class="sailthru_social_conversion"> <div class="sailthru-signup-widget">
    <span class="sailthru-signup-widget-close"><a href="#sailthru-signup-widget">Close</a></span>
     <div class="sailthru_form">

        <div class="widget-title"></div>        <div class="success" hidden="hidden">Thank you for subscribing! Please be sure to open and click your first newsletter so we can confirm your subscription.</div>
         <form method="post" action="#" class="sailthru-add-subscriber-form">
            <div class="sailthru-add-subscriber-errors"></div>

            <div class="sailthru_form_input form-group">
                <label class="sailthru-widget-label">Email</label>
                <input type="text" name="email" value="" class="form-control sailthru_email" />
            </div>

                            <input type="hidden" name="sailthru_nonce" value="a1ee1e5457" />
                <input type="hidden" name="sailthru_email_list" value="Chicago Defender Subscribers" />
                <input type="hidden" name="action" value="add_subscriber" />
                <input type="hidden" name="vars[source]" value="https://chicagodefender.com" />

                <span class="input-group-btn">
                    <button class="btn btn-reverse" type="submit">
                        Submit
                    </button>
                </span>
        </form>



    </div>
</div>
</div>				</div>
							</div>
			<div class="sc-bottom">
				<div class="sc-do-not-show"><a style="color: #ffffff;" href="#"  rel="nofollow">Don't show this to me again</a></div>
				<div class="sc-not-now"><a style="color: #ffffff;" href="#" rel="nofollow">Not
						now</a></div>
			</div>
		</div>
		<div class="sc-overlay"></div>
		<script type="text/javascript">
			var sc_disable_popup = 1;
			var sc_after_share = 1;
			var sc_after_comment = 1;
			var sc_page_number = 2;
			var button_text = "Subscribe Now";
			var widget_id = "ione-social_conversion-15";

			jQuery('#' + widget_id + ' .btn-reverse').text(button_text);

			if (!sc_disable_popup) {
				jQuery(document).ready(function ($) {
					if (sc_page_number && !jQuery.cookie('ione-sc')) {
						var sc_num = 1;
						if (!$.cookie('sc-page-number')) {
							$.cookie('sc-page-number', 1, {path: '/'});
						} else {
							sc_num = parseInt($.cookie('sc-page-number'), 10);
							sc_num++;
							$.cookie('sc-page-number', sc_num, {path: '/'});
						}

						if (sc_num === sc_page_number && ( ione_partners.indexOf(location.hostname) > -1 || location.hostname === 'newsone.com' ))
							setTimeout(function () {
								ione_social_conversion_popup();
							}, 2000);
					}
				});
			}
		</script>
		</div><div id="facebook-likebox-13" class="widget facebook page plugin"><div class="widgettitle"><a href="https://www.facebook.com/TheChicagoDefender/">Follow Us!</a></div>		<div id="fb-root"></div>
		<div class="fb-page" data-href="https://www.facebook.com/TheChicagoDefender/" data-width="340"  data-height="580" data-hide-cover="false" data-show-facepile="true" data-show-posts="true">
		<div class="fb-xfbml-parse-ignore"><blockquote cite="https://www.facebook.com/TheChicagoDefender/"><a href="https://www.facebook.com/TheChicagoDefender/">Follow Us!</a></blockquote></div>
		</div>
		</div>							</div>


						<div class="sidebar-ad second-ad">
							<div class="ione-widget-container ione-widget-ionead">		<div id="ad-sidebar2" data-ad-id="sidebar2" class="ad">
					<div id="div-gpt-sidebar2" class="gpt-ad">
			<script type="text/javascript">
				window.ioneAds.defineSlot( {"name":"sidebar2","path":"\/4052\/thechicagodefender\/desktop","sizes":[[300,250],[300,600]],"div":"div-gpt-sidebar2","targets":{"pos":"2","sz":"300x250,300x600"},"event_render":null,"event_refresh":null,"refresh_interval":null} );
			</script>
		</div>
				</div>
		</div>						</div>
						<div class="sidebar-non-ad above-third-ad">
													</div>

						<div class="sidebar-ad taboola taboola-1">
									<div id="zergnet-widget-58425"></div>
		<script language="javascript" type="text/javascript">
			(function() {
				if ( 'cpc' === ioneAdUtils.getUTM( 'utm_medium' ) ) {
					return;
				}
				var zergnet   = document.createElement('script');
				var znscr     = document.getElementsByTagName('script')[0];
				zergnet.type  = 'text/javascript';
				zergnet.async = true;
				zergnet.src   = (document.location.protocol == "https:" ? "https:" : "http:") + "\/\/www.zergnet.com\/zerg.js?id=58425";
				znscr.parentNode.insertBefore(zergnet, znscr);
			})();
		</script>
		
						</div>

							<div class="sidebar-non-ad above-fourth-ad">
															</div>


							

					</div>
					<div class="sticky-sidebar-ads">
							<div class="sidebar-ad third-ad">
								<div class="ione-widget-container ione-widget-ionead">		<div id="ad-sidebar3" data-ad-id="sidebar3" class="ad">
					<div id="div-gpt-sidebar3" class="gpt-ad">
			<script type="text/javascript">
				window.ioneAds.defineSlot( {"name":"sidebar3","path":"\/4052\/thechicagodefender\/desktop","sizes":[[300,100],[300,250]],"div":"div-gpt-sidebar3","targets":{"pos":"3","sz":"300x100,300x250"},"event_render":null,"event_refresh":null,"refresh_interval":null} );
			</script>
		</div>
				</div>
		</div>							</div>

						</div>
				</div>
				
			</div>
			<!-- .post -->

		</div>
		<!-- .post-wrapper -->

					<div class="ad-single-bottom">
				<div class="ione-widget-container ione-widget-ionead">		<div id="ad-footer" data-ad-id="footer" class="ad">
					<div id="div-gpt-footer" class="gpt-ad">
			<script type="text/javascript">
				window.ioneAds.defineSlot( {"name":"footer","path":"\/4052\/thechicagodefender\/desktop","sizes":[[728,90],[970,66],[970,90],[970,250]],"div":"div-gpt-footer","targets":{"pos":"bottom","sz":"728x90,970x66,970x90,970x250"},"event_render":null,"event_refresh":null,"refresh_interval":null} );
			</script>
		</div>
				</div>
		</div>			</div><!-- /.ad-single-bottom -->
				</div>
	<!-- .post-super-wrapper -->
	
	</div>
<!-- #infinite-scroll-container -->
<div class="ione-widget-container ione-widget-social_conversion">
		<style type="text/css">
			#ione-social_conversion-16 .sailthru-signup-widget button {
				background: #000000;
				color: #ffffff;
			}

			#ione-social_conversion-16 .sc-wrapper {
				border: 1px solid #D3D3D3;
			}

			#ione-social_conversion-16 .sc-wrap img {
				max-width: 100%;
			}

			#ione-social_conversion-16 .sc-newsletter p,
			#ione-social_conversion-16 .sailthru-signup-widget label,
			#ione-social_conversion-16 .sailthru-add-subscriber-errors,
			#ione-social_conversion-16 .sc-share p {
				color: #000000;
			}

					</style>

		<div id="ione-social_conversion-16" class="sc-wrap" style="padding: 20px; background-color: #D3D3D3;">
			<a class="sc-close" style="color: #000000;" rel="nofollow">&times;</a>

			<div class="social-conversion" style="text-align: center;">
								<div class="sc-newsletter">
					<p>SIGN UP FOR THE CHICAGO DEFENDER NEWSLETTER</p><div class="sailthru_social_conversion"> <div class="sailthru-signup-widget">
    <span class="sailthru-signup-widget-close"><a href="#sailthru-signup-widget">Close</a></span>
     <div class="sailthru_form">

        <div class="widget-title"></div>        <div class="success" hidden="hidden">Thank you for subscribing! Please be sure to open and click your first newsletter so we can confirm your subscription.</div>
         <form method="post" action="#" class="sailthru-add-subscriber-form">
            <div class="sailthru-add-subscriber-errors"></div>

            <div class="sailthru_form_input form-group">
                <label class="sailthru-widget-label">Email</label>
                <input type="text" name="email" value="" class="form-control sailthru_email" />
            </div>

                            <input type="hidden" name="sailthru_nonce" value="a1ee1e5457" />
                <input type="hidden" name="sailthru_email_list" value="Chicago Defender Subscribers" />
                <input type="hidden" name="action" value="add_subscriber" />
                <input type="hidden" name="vars[source]" value="https://chicagodefender.com" />

                <span class="input-group-btn">
                    <button class="btn btn-reverse" type="submit">
                        Submit
                    </button>
                </span>
        </form>



    </div>
</div>
</div>				</div>
							</div>
			<div class="sc-bottom">
				<div class="sc-do-not-show"><a style="color: #000000;" href="#"  rel="nofollow">Don't show this to me again</a></div>
				<div class="sc-not-now"><a style="color: #000000;" href="#" rel="nofollow">Not
						now</a></div>
			</div>
		</div>
		<div class="sc-overlay"></div>
		<script type="text/javascript">
			var sc_disable_popup = 0;
			var sc_after_share = 0;
			var sc_after_comment = 0;
			var sc_page_number = 0;
			var button_text = "Submit";
			var widget_id = "ione-social_conversion-16";

			jQuery('#' + widget_id + ' .btn-reverse').text(button_text);

			if (!sc_disable_popup) {
				jQuery(document).ready(function ($) {
					if (sc_page_number && !jQuery.cookie('ione-sc')) {
						var sc_num = 1;
						if (!$.cookie('sc-page-number')) {
							$.cookie('sc-page-number', 1, {path: '/'});
						} else {
							sc_num = parseInt($.cookie('sc-page-number'), 10);
							sc_num++;
							$.cookie('sc-page-number', sc_num, {path: '/'});
						}

						if (sc_num === sc_page_number && ( ione_partners.indexOf(location.hostname) > -1 || location.hostname === 'newsone.com' ))
							setTimeout(function () {
								ione_social_conversion_popup();
							}, 2000);
					}
				});
			}
		</script>
		</div>
	<div class="push-menu-overlay"></div>

	<footer id="footer" class="main-footer" role="contentinfo">



		<ul id="menu-2-footer-links-1" class="secondary-menu footer-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-169905"><a href="https://chicagodefender.com/about/">About</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-182610"><a href="https://chicagodefender.com/dont-miss-an-issue/">Subscribe</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-169906"><a href="https://chicagodefender.com/archives-permissions/">Archives &amp; Permissions</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-86194"><a href="https://chicagodefender.com/privacy-policy/">Privacy Policy</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-86188"><a href="http://interactiveone.com/">Interactive One Affluent</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-169907"><a href="https://chicagodefender.com/contact-us/">Contact Us</a></li>
</ul><ul id="menu-social-media-new-1" class="social-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-155399"><a href="https://www.facebook.com/TheChicagoDefender/"><span>Facebook</span></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-155400"><a href="https://twitter.com/ChiDefender"><span>Twitter</span></a></li>
</ul>
		
		<p>Copyright &copy; 2018 <a href="http://interactiveone.com">Interactive One, LLC</a>.<br class="mobile-only"> All Rights Reserved</p>
		<p>Powered by <a href="https://vip.wordpress.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=chicagodefender.com" rel="generator nofollow" class="powered-by-wpcom">WordPress.com VIP</a></p>

	</footer>
</div><!-- #ione-container opened in header.php -->

		<div id="ad-gravity-ad" data-ad-id="gravity-ad" class="ad">
					<div id="div-gpt-gravity-ad" class="gpt-ad">
			<script type="text/javascript">
				window.ioneAds.defineSlot( {"name":"gravity-ad","path":"\/4052\/thechicagodefender\/desktop","sizes":[],"div":"div-gpt-gravity-ad","targets":{"pos":"skin","sz":"oop"},"event_render":"ione-document-ready","event_refresh":null,"refresh_interval":null} );
			</script>
		</div>
				</div>
		
<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-57e00218cfb6fdb2" async="async"></script>
<!-- wpcom_wp_footer -->
		<div id="fb-root"></div>
		<script>( function( d, s, id ) {
						var js, fjs = d.getElementsByTagName( s )[0];
						if ( d.getElementById( id ) ) {
							return;
						}
						js = d.createElement( s );
						js.id = id;
						js.src = '//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.12';
						fjs.parentNode.insertBefore( js, fjs );
					}( document, 'script', 'facebook-jssdk' ) );</script>
		<script type='text/javascript' src='//0.gravatar.com/js/gprofiles.js?ver=201817y'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/wp-content/mu-plugins/gravatar-hovercards/wpgroho.js?m=1380573781h'></script>

	<script>
		//initialize and attach hovercards to all gravatars
		jQuery( document ).ready( function( $ ) {

			if (typeof Gravatar === "undefined"){
				return;
			}

			if ( typeof Gravatar.init !== "function" ) {
				return;
			}			

			Gravatar.profile_cb = function( hash, id ) {
				WPGroHo.syncProfileData( hash, id );
			};
			Gravatar.my_hash = WPGroHo.my_hash;
			Gravatar.init( 'body', '#wp-admin-bar-my-account' );
		});
	</script>

		<div style="display:none">
	</div>
<script type='text/javascript'>
/* <![CDATA[ */
var HighlanderComments = {"loggingInText":"Logging In\u2026","submittingText":"Posting Comment\u2026","postCommentText":"Post Comment","connectingToText":"Connecting to %s","commentingAsText":"%1$s: You are commenting using your %2$s account.","logoutText":"Log Out","loginText":"Log In","connectURL":"https:\/\/ionechicagodefender.wordpress.com\/public.api\/connect\/?action=request","logoutURL":"https:\/\/ionechicagodefender.wordpress.com\/wp-login.php?action=logout&_wpnonce=eb7a35b94c","homeURL":"https:\/\/chicagodefender.com\/","postID":"203348","gravDefault":"identicon","enterACommentError":"Please enter a comment","enterEmailError":"Please enter your email address here","invalidEmailError":"Invalid email address","enterAuthorError":"Please enter your name here","gravatarFromEmail":"This picture will show whenever you leave a comment. Click to customize it.","logInToExternalAccount":"Log in to use details from one of these accounts.","change":"Change","changeAccount":"Change Account","comment_registration":"","userIsLoggedIn":"","isJetpack":"","text_direction":"ltr"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s2.wp.com/_static/??/wp-content/js/jquery/jquery.autoresize.js,/wp-content/mu-plugins/highlander-comments/script.js?m=1521806916j'></script>
<!-- Sailthru Horizon Sync -->
<script type="text/javascript" src="//ak.sail-horizon.com/horizon/v1.js"></script>
<script type="text/javascript">
jQuery(function() { 
  if (window.Sailthru) {
           Sailthru.setup({
              domain: 'horizon.chicagodefender.com',concierge: {
	 			from: 'top',
	 			threshold: 500,
	 			delay: 100,
	 			offsetBottom: 150,
	 			cssPath: 'https://ak.sail-horizon.com/horizon/recommendation.css',
	 			
	 		}
         });
  }
});
 </script>

	<div id="carousel-reblog-box">
		<form action="#" name="carousel-reblog">
			<textarea id="carousel-reblog-content" name="carousel-reblog-content" placeholder="Add your thoughts here... (optional)"></textarea>
			<label for="carousel-reblog-to-blog-id" id="carousel-reblog-lblogid">Post to</label>
			<select name="carousel-reblog-to-blog-id" id="carousel-reblog-to-blog-id">
						</select>

			<div class="submit">
				<span class="canceltext"><a href="#" class="cancel">Cancel</a></span>
				<input type="submit" name="carousel-reblog-submit" class="button" id="carousel-reblog-submit" value="Reblog Post" />
				<input type="hidden" id="carousel-reblog-blog-id" value="56132093" />
				<input type="hidden" id="carousel-reblog-blog-url" value="https://chicagodefender.com" />
				<input type="hidden" id="carousel-reblog-blog-title" value="The Chicago Defender" />
				<input type="hidden" id="carousel-reblog-post-url" value="" />
				<input type="hidden" id="carousel-reblog-post-title" value="" />
			</div>

			<input type="hidden" id="_wpnonce" name="_wpnonce" value="2bd9313a39" /><input type="hidden" name="_wp_http_referer" value="/2018/04/24/meek-mill-released-from-prison-looks-forward-to-resuming-music-career/" />		</form>

		<div class="arrow"></div>
	</div>
<link rel='stylesheet' id='all-css-0-3' href='https://s1.wp.com/wp-content/mu-plugins/carousel/jetpack-carousel.css?m=1481571546h&cssminify=yes' type='text/css' media='all' />
<!--[if lte IE 8]>
<link rel='stylesheet' id='jetpack-carousel-ie8fix-css'  href='https://s1.wp.com/wp-content/mu-plugins/carousel/jetpack-carousel-ie8fix.css?m=1412618825h&#038;ver=20121024' type='text/css' media='all' />
<![endif]-->
<script type='text/javascript' src='https://s1.wp.com/_static/??/wp-content/js/devicepx.js,/wp-content/mu-plugins/likes/queuehandler.js?m=1519172360j'></script>
<script type='text/javascript' src='https://pdk.theplatform.com/pdk/tpPdkController.js?ver=0.2.5'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ione3Scroll = {"sis_api_url":"https:\/\/chicagodefender.com\/wp-json\/sis\/v1\/post\/","post_id":"203348","post_type":"post","is_single":"1","activated":"","nonce_single_infinite_scroll":"7c52cb2d46"};
var ione3Gallery = {"ad_frequency":"5","refresh_728":"3","refresh_300":"3","refresh_mobile_300":"3","refresh_anchor":"3","nav_delay":"","inner_ad_delay":"3000","ione3_gallery_nonce":"c3139de7f8","baseURL":"https:\/\/chicagodefender.com\/2018\/04\/24\/meek-mill-released-from-prison-looks-forward-to-resuming-music-career\/","gallery_type":"post"};
var comscore = {"id":"6035391","pv":"https:\/\/chicagodefender.com\/wp-content\/themes\/vip\/ione3\/comscore_pageview.txt"};
var ione3Theme = {"stylesheet":"chicagodefender","admin_bar":""};
var ione_video_grid_settings = {"ajax_url":"https:\/\/ionechicagodefender.wordpress.com\/wp-admin\/admin-ajax.php","categoryid":"","max_pages":"0","current_page":"1","security":"1429153053"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpUtilSettings = {"ajax":{"url":"\/wp-admin\/admin-ajax.php"}};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var ioneSearch = {"ajaxUrl":"https:\/\/ionechicagodefender.wordpress.com\/wp-admin\/admin-ajax.php","ajaxNonce":"4494a1a7d9","baseUrl":"https:\/\/ionechicagodefender.wordpress.com"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var jpfbembed = {"appid":"249643311490","locale":"en_US"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcomVipAnalytics = {"is_404":"0","is_home":"0","is_single":"1","is_front_page":"0","is_archive":"0","percentToTrack":"1"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/chicagodefender.com\/wp-admin\/admin-ajax.php","nonce":"eee0ea8730","display_exif":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/ionechicagodefender.wordpress.com\/wp-login.php?redirect_to=https%3A%2F%2Fchicagodefender.com%2F2018%2F04%2F24%2Fmeek-mill-released-from-prison-looks-forward-to-resuming-music-career%2F","blog_id":"56132093","local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>","reblog":"Reblog","reblogged":"Reblogged","reblog_add_thoughts":"Add your thoughts here... (optional)","reblogging":"Reblogging...","post_reblog":"Post Reblog","stats_query_args":"blog=56132093&v=wpcom&tz=-5&user_id=0&subd=ionechicagodefender","is_public":"1","reblog_enabled":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://s2.wp.com/_static/??-eJyVUtlywjAM/KEqpkmP6UOnn8IotgAFH6mPAP36CpgwTAsBnmyvvLteWWrTgw4+k88qr8hRUgP3ioOnRrHXthiBXDDFyrqHYcFbMjCwoaDO9lWXntSUGqZEOanuKNNUjv3IORlJsUW9buXCtbocS2Y7Ub6kcO+r5okw6tWD1IG8CVF134XiDrDDLdig0aYcIi4JNOoV3Sj/tXMFeluW7MWBci+Z1FyCqgVqakNYA7mWzL2svOGcKUJmR5b9lFsN+4jdISmgR7vLrNNEN0aixZ+dBEMDs+p9L3AMXKXgMd7o6FWNEzDxYjQiLt8elcMkKWUHYaAY+TC8I/agQo7SvXRpxlJ/efaOeU+x+/+Jzyw1xlAS2fGfYASE8+U+n1/rl7dZ81HX3S/06ln9'></script>
<script type="text/javascript">
// <![CDATA[
(function() {
try{
  if ( window.external &&'msIsSiteMode' in window.external) {
    if (window.external.msIsSiteMode()) {
      var jl = document.createElement('script');
      jl.type='text/javascript';
      jl.async=true;
      jl.src='/wp-content/plugins/ie-sitemode/custom-jumplist.php';
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(jl, s);
    }
  }
}catch(e){}
})();
// ]]>
</script><script src="//stats.wp.com/w.js?56" type="text/javascript" async defer></script>
<script type="text/javascript">
_tkq = window._tkq || [];
_stq = window._stq || [];
_tkq.push(['storeContext', {'blog_id':'56132093','blog_tz':'-5','user_lang':'en','blog_lang':'en','user_id':'0'}]);
_stq.push(['view', {'blog':'56132093','v':'wpcom','tz':'-5','user_id':'0','post':'203348','subd':'ionechicagodefender'}]);
function st_vt() {var x=document.createElement("img");x.src="https://pixel.wp.com/g.gif?blog=56132093&v=wpcomvt&tz=-5&user_id=0&post=203348&subd=ionechicagodefender&rand="+Math.random();}
_stq.push(['extra', {'crypt':'UE40eW5QN0p8M2Y/RE1BNmNJfGhxNCVxUDExYmtib2E/SzdEJm0lUEtbdFU0fFk4cHZvcUFrZT90Tn4yQm1+R3NyNTdRWndQSU9QW1pBXzBuNHlUVS85UXVLb3EmZk4mR1JqZjdPdltNZllUSV9BSzRzZCY4bCU0bixweHBUelVGW34vSGguY190NlFvOEJDPWYmUkVlWCxtVFg5QWZ3dS8vd3Z1RS9pd0hsYT9zbGEtYSxofnJmYV1STHQ/akNsVGcuLl1VNERLKzI/X3NBVnBvWCtVLH5iaT9JTzVUMkdjXThQK19GfjJjaGdYN0hCWjR3emdJcFs2PUUlUT9EdVQ/NEVacHFleTh8YWRDeEtMWlNaZDUtUSZTNXk='}]);
_stq.push([ 'clickTrackerInit', '56132093', '203348' ]);
	</script>
<noscript><img src="https://pixel.wp.com/b.gif?v=noscript" style="height:0px;width:0px;overflow:hidden" alt="" /></noscript>
<script>
if ( 'object' === typeof wpcom_mobile_user_agent_info ) {

	wpcom_mobile_user_agent_info.init();
	var mobileStatsQueryString = "";
	
	if( false !== wpcom_mobile_user_agent_info.matchedPlatformName )
		mobileStatsQueryString += "&x_" + 'mobile_platforms' + '=' + wpcom_mobile_user_agent_info.matchedPlatformName;
	
	if( false !== wpcom_mobile_user_agent_info.matchedUserAgentName )
		mobileStatsQueryString += "&x_" + 'mobile_devices' + '=' + wpcom_mobile_user_agent_info.matchedUserAgentName;
	
	if( wpcom_mobile_user_agent_info.isIPad() )
		mobileStatsQueryString += "&x_" + 'ipad_views' + '=' + 'views';

	if( "" != mobileStatsQueryString ) {
		new Image().src = document.location.protocol + '//pixel.wp.com/g.gif?v=wpcom-no-pv' + mobileStatsQueryString + '&baba=' + Math.random();
	}
	
}
</script></body>
</html>
